Jump to content
Jagman13

Native update anytime soon?

Recommended Posts

Any news of an update from 1.5 in the pipeline?

What is the usual kind of update cycle with line 6 and helix ? Seems ages since the last one and seems very quiet in here.. 

 

  • Like 1

Share this post


Link to post
Share on other sites

Personally, I'd like to see direct MIDI control support added, and a fix for the Logic Pro Snapshot automation bug.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, Jagman13 said:

Also... Lots of new amp models to play with too please :) 

It's always fun to get new amps and effects in updates, but there are more amps and effects I don't use than do use because there are already so many!  It's funny, and maybe human nature, but I try out the new amps and add effects, change settings, etc., and this new preset sounds great.  Then I realize later it sounds similar to other presets I made!  I only write and record my music (I'm not trying to get anyone else's tone) so I subconsciously gravitate towards my tone and have to consciously move out of that box.  In fact in my latest song, for the first time I used the Fawn amp and my dual humbucker music man guitar sounds like a strat, and I also own and play a Strat - ironic!

 

But I'm not criticizing your desire - we all want more and trying out new stuff is fun.  I'm a huge Cartographer fan so that was worth that update alone.  But I have a serious IR problem - I've bought waaaay to many and am always looking for that magical new tone and sometimes it does happen.

 

 

Share this post


Link to post
Share on other sites

I agree .... I could spend years playing with all of the amps and effects in Helix Native, but I've settled in on some amp and IR cab combos that I almost always use. Then I select effects based on the song I'm recording. When it comes to an update, my number 1 wish would be for better performance when using multiple core systems .... Helix Native can really load my system and DAW when recording. I've got more than enough amps for now!

Share this post


Link to post
Share on other sites

Doug6String, Agree it can go that way at times and listening back to my fav patches they do tend sound similar, but its also nice to try a new patch and go "ohhhh" and that inspires you in a new direction too :) There are some amazing patches that others have made in the Custom tone and to be able to dial them up in an instant wow! 

 

Soundog, With you on the CPU hog..we have been there before ;) Quick update on that... When I am multi tracking now I use a simple mono patch with almost no bells and whistles on it and a single mono track in Logic.  Then when I have finished tracking I beef the tones up and add sparkle and shine to them and then render them to audio tracks. Still not perfect but it does allow me to get on and actually compose... although not too sure the composition at the end is any good but the guitars sound great! :) 

 

Lets hope L6 can reduce the CPU hog and get the basics for automation in place and we will be in a good place :)

 

Back to work...which IR shall I use with the PV Panama... hmm 5 hours later... :)

 

 

Share this post


Link to post
Share on other sites

Jagman --- similar to what I'm doing these days; keeping the Helix stuff simple until I polish it later, and sometimes freezing the track. BTW, I picked up Fremen's latest set of presets (the V2.5) and its turning out to be what I try first on tracks when I want great tone without much fuss. And it comes with even more IRs!

Share this post


Link to post
Share on other sites
4 hours ago, Jagman13 said:

Doug6String, Agree it can go that way at times and listening back to my fav patches they do tend sound similar, but its also nice to try a new patch and go "ohhhh" and that inspires you in a new direction too :) There are some amazing patches that others have made in the Custom tone and to be able to dial them up in an instant wow! 

 

Soundog, With you on the CPU hog..we have been there before ;) Quick update on that... When I am multi tracking now I use a simple mono patch with almost no bells and whistles on it and a single mono track in Logic.  Then when I have finished tracking I beef the tones up and add sparkle and shine to them and then render them to audio tracks. Still not perfect but it does allow me to get on and actually compose... although not too sure the composition at the end is any good but the guitars sound great! :) 

 

Lets hope L6 can reduce the CPU hog and get the basics for automation in place and we will be in a good place :)

 

Back to work...which IR shall I use with the PV Panama... hmm 5 hours later... :)

 

 

 

2 hours ago, soundog said:

Jagman --- similar to what I'm doing these days; keeping the Helix stuff simple until I polish it later, and sometimes freezing the track. BTW, I picked up Fremen's latest set of presets (the V2.5) and its turning out to be what I try first on tracks when I want great tone without much fuss. And it comes with even more IRs!

I have resigned myself to rendering tracks (I use Studio One 4) when Native starts overwhelming my PC.  I have to comment on the Fremens - for me, they are the only presets I ever bought that I use (I bought the Mega Pack).  I've tried a few of the others that many like, but they didn't do it for me.  Fremen's are different.  In fact in a song I was working on last night I ended up using one with the Fawn Brt and my Music Man with humbuckers ended up sounding like my Strat, which was great for that section of the song!  Man, I love being alive now!  

Share this post


Link to post
Share on other sites

Just had a look at the Fremens website, they do sound good on the demos.. hmmm recommended buy then and easy enough to use in native? 

Share this post


Link to post
Share on other sites

Yeah, works seamlessly in Native, and uses Snapshots also. My fave is the new 2.5 release, but others are good also. Some do use some horsepower in Native, but you can tweak as needed.

Share this post


Link to post
Share on other sites

Update should be coming very soon... MIDI control will be part of it (along with a few other neat things).

  • Like 1

Share this post


Link to post
Share on other sites

That's encouraging Phil, thanks. A few other neat things? Bring 'em on!

Share this post


Link to post
Share on other sites

Finally got the fremens update pack 2.5 ... they are very good indeed straight out the box.  The Friedman’s are just fantastic.. :).

Going to have a play around later and add different amps and IRS to these ones.. have you guys tried it and got some good results? 

 

Phil.. great news.. any idea when? :) 

 

 

Share this post


Link to post
Share on other sites

....I've played around with tweaking the Fremen presets with different IRs and amps, but was always happier in the end with his choices. I usually only tweak amp gain and eq, and FX block on/off/levels.

Share this post


Link to post
Share on other sites

SNAPSHOT HELL:  I started with Native and I absolutely love it. I have virtually zero need for a Helix floor unit but I recently bought one, and now I am wondering why. I think it was for 3 reasons;  1). I was convinced that it would somehow sound better with its own proprietary audio interface than Helix Native. In my opinion it does not. 2). I thought that the floor unit and Native would communicate with one another and that I could use the hardware to change snapshots in Native. 3). The main reason was because I was never able to find a 100% reliable means for changing Snapshots. I figured something out but there was too much perpetual fiddling around to make it viable. It's true that when I am recording small clips and creating tracks with one tone snapshots are not a must so Native should do as it is, but when I want to casually play guitar and have the snapshots available on the fly I am still stuck. Trying to use my new Helix LT as an alternative to Native when laying down multiple tracks is a huge PITA and not nearly as versatile as native with its plugin convenience. But spending this kind of money just to have snapshots at my feet along with a more complicated work-flow is ridiculous. What would still make all of this worthwhile would be if Line 6 had designed the floor units and Native to actually communicate with one another. If I could change my Native snapshots from the Helix Lt I would feel a lot better about this. At this point the Helix Lt is going back. In this case (and I know my needs may differ from others) Line 6 is losing a $1,200 sale simply because of this snapshot issue. 

 

Does anyone know if there are any plans for Line 6 to further integrate the two? Or, are there any plans for Line 6 to update Native so that the snapshots will work with midi in a traditional manner, like they did with the rest of the Native settings? Why would they leave snapshots out of this equation? So many people have complained about this you would think that they would just fix it with an update.  Are there any new midi controller workarounds for snapshots? (I use Logic Pro X)

Share this post


Link to post
Share on other sites
31 minutes ago, Petes63Strat said:

Does anyone know if there are any plans for Line 6 to further integrate the two? Or, are there any plans for Line 6 to update Native so that the snapshots will work with midi in a traditional manner, like they did with the rest of the Native settings? Why would they leave snapshots out of this equation? So many people have complained about this you would think that they would just fix it with an update.  Are there any new midi controller workarounds for snapshots? (I use Logic Pro X)

 

Not sure I understand what you mean by "MIDI traditional manner", but you can recall snapshot in Native via MIDI as it stands now. MIDI CC#69, values 0-7 recalls Snapshot 1 - 8, respectively. If you want to use the Helix LT to recall snapshots in Native, you could do so pretty easily using one Instant Command (the lightning bolt icons in the Command Center). You'd just set one of them to be CC#69 and set the appropriate value in each snapshot. It's really that simple.

Share this post


Link to post
Share on other sites

I also use Logic Pro X, and it works best for me to simply use a Logic automation lane to control Snapshots. This is my workflow for recording a guitar track within a song:

 

1) set up a HXN preset that fits the song, along with Snapshots as needed for parts of the song (chorus, verse, etc).

2) set up a Logic automation lane to switch HXN Snapshots automatically as I record the guitar (this assumes the tempo track of the song is already in place)

3) record the guitar track real-time (using software monitoring). If I don't have enough horsepower to get the latency down low enough, I will temporarily freeze all my other tracks first (especially virtual instrument tracks). This step is just to get a "raw" guitar track recorded, while still hearing the modeling and effects within HXN to get a better feel. Another reason I like Logic to take care of the "foot work" is that I can focus on the guitar playing without thinking about the controls.

4. after the raw guitar track is recorded, I can later tweak HXN if needed during mixing.

5. After I've got the track where I like it (late in the mixing process), I bounce it to audio and remove the HXN plugin, to free up CPU. 

6. When I archive the song, I save and include the Helix preset, as well as the raw recorded guitar track(s).

 

Share this post


Link to post
Share on other sites
1 hour ago, phil_m said:

 

Not sure I understand what you mean by "MIDI traditional manner", but you can recall snapshot in Native via MIDI as it stands now. MIDI CC#69, values 0-7 recalls Snapshot 1 - 8, respectively. If you want to use the Helix LT to recall snapshots in Native, you could do so pretty easily using one Instant Command (the lightning bolt icons in the Command Center). You'd just set one of them to be CC#69 and set the appropriate value in each snapshot. It's really that simple.

 

 

Phil_m:  Thanks for weighing in. This is encouraging! I did try this yesterday with the lightning bolts but did not have success. Since you have it working I will definitely get back into it right now and report back.

 

Soundog:  Your comments make perfect sense too and I had dug into that a little when I read where you mentioned this a while back. My real issue was trying to do it on the fly, more free form. But you are right about being able to focus on playing and not have to worry about pressing buttons during a session. If I can get it to work as phil_m suggests I will have the best of both worlds and that would be idea. I like your work flow and appreciate your sharing it. I'll let you know how I make out.

 

Thanks guys.

Share this post


Link to post
Share on other sites

....not sure if you mentioned  if you were using the latest version of HXN or not, but I think MIDI Snapshot support was added with V1.7 and didn't appear in early versions.

Share this post


Link to post
Share on other sites
2 hours ago, phil_m said:

 

Not sure I understand what you mean by "MIDI traditional manner", but you can recall snapshot in Native via MIDI as it stands now. MIDI CC#69, values 0-7 recalls Snapshot 1 - 8, respectively. If you want to use the Helix LT to recall snapshots in Native, you could do so pretty easily using one Instant Command (the lightning bolt icons in the Command Center). You'd just set one of them to be CC#69 and set the appropriate value in each snapshot. It's really that simple.

 

 

phil: I am trying to set this us right now. Am I supposed to I apply these settings to only the lightning bolts (top) or do I also have to apply them to the corresponding foot switch icons below (like the first 4 buttons from left to right on the bottom row, for example)? I reread what you wrote and then tried to apply it to only the 1st lightning bot, then I applied setting to each of the 4 foot switches setup like this:

 

1st switch: MiddCC - Channel 1 - CC#69 - Value 0

2nd switch: MidiCC - Channel 1- CC#69 - Value 1

and so forth for 3-4

 

I don't seem to be getting and midi signal to my Mac even when I run my midi analyzer amp

 

 

 

 

Share this post


Link to post
Share on other sites

Yes, soundog. I am on the latest. I am trying to follow phil's idea above but I am not getting any midi signal to Logic (?)

Share this post


Link to post
Share on other sites
1 minute ago, Petes63Strat said:

 

phil: I am trying to set this us right now. Am I supposed to I apply these settings to only the lightning bolts (top) or do I also have to apply them to the corresponding foot switch icons below (like the first 4 buttons from left to right on the bottom row, for example)?

 

You only need to use one of the lighting bolt icons. Select MIDI CC, and set it to CC64. Assuming you're in a blank preset, you should be in Snapshot 1, so set the value for this CC to 0. Save the snapshot/preset if you don't have the Snapshot Edits parameter set to Recall. Now change to Snapshot 2 on the LT and then change the value to 1. Assuming you'd want to be able to recall every snapshot from the LT,  you'd need to set the value in each of the LT's 8 snapshot. Then if you go into Snapshot Mode on the LT, when you recall Snapshot 2, for instance, Native will follow suit.

Share this post


Link to post
Share on other sites
4 minutes ago, Petes63Strat said:

Yes, soundog. I am on the latest. I am trying to follow phil's idea above but I am not getting any midi signal to Logic (?)

 

Do you have the LT selected as a MIDI device in Logic? You have to do this separately from setting it up as an audio device.

Share this post


Link to post
Share on other sites
8 minutes ago, phil_m said:

 

Do you have the LT selected as a MIDI device in Logic? You have to do this separately from setting it up as an audio device.

 

 

No. That's a good point though. Do you mean by setting it up as a controller? I find no other midi choice this through "preferences" and if I try through Controller Assignments it is not recognized (like my keyboards are, for example). How are you do this? By the way, I really appreciate your help here. I feel like there may be hope :)

Share this post


Link to post
Share on other sites
8 minutes ago, Petes63Strat said:

No. That's a good point though. Do you mean by setting it up as a controller? I find no other midi choice this through "preferences" and if I try through Controller Assignments it is not recognized (like my keyboards are, for example). How are you do this? By the way, I really appreciate your help here. I feel like there may be hope :)

 

I'm afraid I can't be of much help with Logic, as I have very limited experience with it. But I think, yes, it should show up in the Controller Assignments tab. If it were Reaper, I could give you step by step instructions.

Share this post


Link to post
Share on other sites

Okay. I thought you were using Logic. This has been my issue with Logic all along. I have searched throughout Logic and cannot find a way to "add Helix" as a specific midi controller. There is  a"learn" feature but no luck their either when trying through Helix LT. Thanks again though. I keep trying.

Share this post


Link to post
Share on other sites

The one thing that still troubles me is that I cannot detect any midi signal from my Helix LT to my Mac. Not within Logic Pro or even with one of my little Midi detector utilities. If i plug in a keyboard via USB and touch anything the utilities light up and there are midi signals streaming, but nothing from Helix. I checked my Global settings on Helix and it's set for Midi Base Channel 1. Not sure why I am not getting any signal.

Share this post


Link to post
Share on other sites
9 minutes ago, Petes63Strat said:

Okay. I thought you were using Logic. This has been my issue with Logic all along. I have searched throughout Logic and cannot find a way to "add Helix" as a specific midi controller. There is  a"learn" feature but no luck their either when trying through Helix LT. Thanks again though. I keep trying.

 

Just remembered one thing... On the LT, go to Global Settings>MIDI/Tempo and make sure MIDI Over USB is turned on. I believe it's off by default.

Share this post


Link to post
Share on other sites
23 minutes ago, Petes63Strat said:

Thanks, Yes. I do have that selected.

 

You said USB audio is working through the LT, though, correct?

 

I'm not sure what else it could be, really. If you turn on Receive MIDI Clock in the LT, does the tap tempo LED turn blue when you hit play in Logic?

Share this post


Link to post
Share on other sites

No. When I hit Play on Logic the tempo led ring just continues to flash to whatever it was previously set to, no change. I play with those setting but no change in that led.

 

I was able to get my expression pedal to also show midi activity but still nothing on the desired switches.

Share this post


Link to post
Share on other sites
22 minutes ago, Petes63Strat said:

No. When I hit Play on Logic the tempo led ring just continues to flash to whatever it was previously set to, no change. I play with those setting but no change in that led.

 

I was able to get my expression pedal to also show midi activity but still nothing on the desired switches.

 

Well if the expression pedal is passing MIDI, then there must be some MIDI communication happening.

 

Do you have the LT in Stomp Mode or Snapshot Mode. The method I'm describing above would work with Snapshot Mode. You could also assign the MIDI CC directly to the footswitches in Stomp Mode, I suppose. It's just that if you use Snapshot Mode to change snapshots, it frees up the Stomp Mode switches to be used for other things if you want.

  • Like 1

Share this post


Link to post
Share on other sites

So give me the short version of what you're trying to do and I'll see if I can do some troubleshooting over the next day and see what works for me. (I've got an HX Effect, which has the same Command Center as Helix floor).

 

Can I assume you want to control Snapshots real-time in HXN using your Helix hardware, and using USB as your interface?

  • Like 1

Share this post


Link to post
Share on other sites

...that looks very useful, thank rsvette, I'll have a look at the whole thing later. petestrat guy, let us know if you get it working in the meantime....

  • Like 1

Share this post


Link to post
Share on other sites

Phil: Yes, I am in Snapshot mode. I was also able to finally get the buttons to deliver some midi activity but nothing that really made sense. EX: For some reason  one click of the first button would yield 3 separate control change messages n a row. I want to be clear on one thing: Early on in your initial suggestion for using the lightning bolt: If I want to to use the A-D Bottom row snapshot switches, Which lightning bolt am I supposed to setup with the CC#69 & 0 command, and do I setup only ONE lightning bolt, then do I setup A-D with the CC#69 and 0,1,2,3 across the 4 respective buttons? Or do I still have this wrong?

Share this post


Link to post
Share on other sites

Hers another one Studio One is so easy to work with - never looked back

 

 

Share this post


Link to post
Share on other sites

Thanks, Rich. I saw that video but it does not pertain to this exact situations. I appreciate it though. It does have good info and is worth a watch for other situation.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×