Jump to content
phil_m

Helix/HX Effects Firmware Update Instructions - Please Read before posting a new thread!

Recommended Posts

6 hours ago, gdimeris said:

Thank you! Yes, I did download the 1.80 Native download separately and tried to run it. I'll try again later. A few hours of sleep work wonders sometimes ; )

Yep! Sleep helped. All good now : ) I was trying to update Native 1.70 to Native 1.80 using an .exe on a Mac. Not happenin'. Dayum, brainz.

  • Thanks 1

Share this post


Link to post
Share on other sites

Updated with factory presets and user imports with no issues.

 

Special thanks to Line 6 staff for the impressive effort.  Well done.

Share this post


Link to post
Share on other sites

Updated mine today with no issues.

 

Is it me or do the presets sound possibly a little brighter than before the update.

Share this post


Link to post
Share on other sites
6 minutes ago, sdard1 said:

Updated mine today with no issues.

 

Is it me or do the presets sound possibly a little brighter than before the update.

 

Did you restore from backup? If you didn't, all the Global Settings, including the Global EQ, would be reset to their defaults, so this could make a difference in the way things sound.

Share this post


Link to post
Share on other sites
13 minutes ago, phil_m said:

 

Did you restore from backup? If you didn't, all the Global Settings, including the Global EQ, would be reset to their defaults, so this could make a difference in the way things sound.

 

Great tip.  I'll restore the backup and see if I notice a difference.   The tone is great as is and I might just be imagining things.

Share this post


Link to post
Share on other sites

Haven't played through it yet, but update went without a hitch.  Didn't even have to reload presets or setlists.

 

I find that the snark provided in L6T's and DI's instructions and advice keep me on task and following instructions.

Share this post


Link to post
Share on other sites

My HX Edit under file, there is no option to back up anything. HX Edit is on 2.1 I think. 

Share this post


Link to post
Share on other sites
On 7/13/2018 at 6:15 AM, sb77 said:

Just a reminder (cos I forgot between updates....!) that if you get repeated failures with applying the update then check you haven't got MIDI In (5 pin) connected.

Leaving a MIDI in connected stops the update dead - remove it - worked first time!

 

Maybe next time I will remember this myself....

 

Thank you so much for this! This should really be in the instructions.

  • Like 1

Share this post


Link to post
Share on other sites

 

Bad experience with line 6 and its update, also my helix got stuck and still stuck, I lost a morning of work trying to solve the problem and through the forum I realize that I am not the only one. Things like that make distrust of updates. the suggestions described here have not helped me so tomorrow I will lose another work day going where I bought it to take care of the problem (line 6 problem), very disagreeable so f

Share this post


Link to post
Share on other sites
10 minutes ago, rojasred said:

 

Bad experience with line 6 and its update, also my helix got stuck and still stuck, I lost a morning of work trying to solve the problem and through the forum I realize that I am not the only one. Things like that make distrust of updates. the suggestions described here have not helped me so tomorrow I will lose another work day going where I bought it to take care of the problem (line 6 problem), very disagreeable so f

 

Sorry to hear that you're having a difficult time. Could you provide some more detail? What type of computer/OS are you using, and what have you tried so far?

Share this post


Link to post
Share on other sites
On 7/25/2019 at 4:19 PM, rojasred said:

 

Bad experience with line 6 and its update, also my helix got stuck and still stuck, I lost a morning of work trying to solve the problem and through the forum I realize that I am not the only one. Things like that make distrust of updates. the suggestions described here have not helped me so tomorrow I will lose another work day going where I bought it to take care of the problem (line 6 problem), very disagreeable so f

I'm in the same boat. Software now isn't recognizing the Helix considering the Helix failed (as shown on the screen) and had been that way for roughly 5-6 hours. 

Tomorrow's another day!

Share this post


Link to post
Share on other sites
HELP! I started running the 2.8 update last night. Followed all the instructions, launched the update. Got to the halfway point when it is supposed to reboot, clicked OK, and then it sat there with no progress. I let it run all night (turned off sleep settings on the computer) - this morning it still had not progressed at all. I have now tried:
  • reloading HX edit
  • different PC
  • rebooting helix
  • rebooting helix in update mode
  • rebooting helix to factory default
My computers "see" the helix (it notifies me when I plug in the usb port), so not a bad USB cable. However lin6 updater does not recognize the device on either computer.
 
I need this unit for tomorrow, and I need to practice - any hints?

Share this post


Link to post
Share on other sites
1 hour ago, mathias8 said:
My computers "see" the helix (it notifies me when I plug in the usb port), so not a bad USB cable. However lin6 updater does not recognize the device on either computer.
 
I need this unit for tomorrow, and I need to practice - any hints?

I know you said your USB cable is OK, but could it be that when you got the second "reset" message you had to turn off and switch to a different USB port? That's the only thing I can think of right now...You might need to try the installation again, to pick up from the second "reset." Good luck!

Quote

If Helix appears to not respond for many minutes, turn Helix off, connect to a different USB port on your computer, and attempt the update again.

Share this post


Link to post
Share on other sites

My update hung after the mid-update reboot, and I couldn't get the Helix to connect to the PC after cancelling it.

 

After trying a few things, I reinstalled HX Edit (for a third time) but this time, I installed all three drivers listed instead of nixing the HX Stomp and WinUSB (which description said "HX Effects drivers") which I had unchecked previously because I don't have an HX Stomp or HX Effects. It could be a coincidence, but that got my Helix Floor to show up against in Line6 Update and a re-update went smoothly.

 

It might have been a coincidence and something else was the problem, but Line6 might want to double check if one of those two other drivers is necessary for a clean update because I can understand why people who don't have an HX Effect/Stomp might uncheck those boxes like I did. If so, it should either not be uncheckable, or at least the update instructions should indicate not to uncheck them :)

Share this post


Link to post
Share on other sites

HELP!!!...When I followed all the directions from everywhere...I got my hx stomp on 2.8 and I see all the new effects but not on hx edit. new effects are just a blank block.  When I try follow the prompts on my mac for hx edit, it keeps saying 2.71 on everything.  I know I'm not clicking 2.71 so I'm not seeing what the problem is.....

 

Line 6 downloads page, middle bar hx edit, right bar operating system, hit go, click get now....done it too many times.  I don't know whats going on.  Everyone just keeps telling me you have to update your hx edit :/ 

Share this post


Link to post
Share on other sites
39 minutes ago, Dannyboy617 said:

HELP!!!...When I followed all the directions from everywhere...I got my hx stomp on 2.8 and I see all the new effects but not on hx edit. new effects are just a blank block.  When I try follow the prompts on my mac for hx edit, it keeps saying 2.71 on everything.  I know I'm not clicking 2.71 so I'm not seeing what the problem is.....

 

Line 6 downloads page, middle bar hx edit, right bar operating system, hit go, click get now....done it too many times.  I don't know whats going on.  Everyone just keeps telling me you have to update your hx edit :/ 

 

Hi Danny,

 

Why are you following "all the directions from everywhere?"
 

Do that and confusion will happen - follow the one set of instructions that are supplied on the download page for v2.80

 

That 88MB file is the only thing you need to download. When you launch the file which is named "HXEdit2.80.dmg" it contains the latest Line 6 Updater app, any required drivers and HX Edit 2.8 app. It appears to me that you must still have a copy of HX Edit 2.71 on your Mac and that is not compatible with the new firmware. Find and delete any old copies of HX Edit prior to 2.80. You might have an alias on your system pointing to the wrong version.

 

If after deleting the other versions you cannot find HX Edit 2.80, the simplest thing to do is launch the HXEdit2.80.dmg and double click HX Edit.pkg to open the installer, click Continue 3 times and then click "Agree". On the next page at the lower left hand side click the "Customise" button. In the next window leave the tick in the box for HX Edit, but leave the box for Line 6 Updater an empty box. Click install and when it finishes, the only copy of HX Edit on your computer will be the correct one! You can then enjoy your new Firmware.

 

There you are. Now I have become of those - "Everyone just keeps telling me you have to update your HX Edit" - because it's true!

 

 

 

Share this post


Link to post
Share on other sites

I'm having a weird issue.I updated succesfully to 2.80 but when I try to update to 2.80.1 , I get this 

''HX Effects Firmware Update Suspended

 HX Effects did not reset instructing it to enter DFU mode.

 1.Click 'OK', then cycle power the unit.''

and if i try to enter by holding down the ''>'' button  the hx effects screens are all blank.

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, DimSam said:

I'm having a weird issue.I updated succesfully to 2.80 but when I try to update to 2.80.1 , I get this 

''HX Effects Firmware Update Suspended

 HX Effects did not reset instructing it to enter DFU mode.

 1.Click 'OK', then cycle power the unit.''

and if i try to enter by holding down the ''>'' button  the hx effects screens are all blank.

 

Hi,

 

DELETED!

 

Comment updated:

I couldn’t see the “Hot Fix” on first checking - it is definitely there now though!

Don’t have a HXFX Box so I’m not sure what the issue is.

Edited by datacommando
MISINFORMATION - REMOVED

Share this post


Link to post
Share on other sites
10 hours ago, datacommando said:

You really are having a weird issue - update to 2.80.1 is not available for download.

HX Effects 2.80.1 Hot Fix is avialable for download.

Share this post


Link to post
Share on other sites
3 minutes ago, zolko60 said:

HX Effects 2.80.1 Hot Fix is avialable for download.

 

Thanks 

 

I retract my previous comments,  must have been my medication - I can see it now.

 

But do you also have a solution for “DimSam” and the issues with the “Hot Fix”?

  • Upvote 1

Share this post


Link to post
Share on other sites
6 minutes ago, datacommando said:

But do you also have a solution for “DimSam” and the issues with the “Hot Fix”?

Nope.

  • Thanks 1

Share this post


Link to post
Share on other sites

Reposted('cos this seemed like the right topic for it):

Would love to hear a comment by DI, phil_m or someone with some actual knowledge as to the nuts and bolts of how setlists and presets are updated in new firmware.

 

You know I could be wildly incorrect here but I have seen so many posts and topics regarding problems with legacy presets from a prior version of the firmware. I know some of those bugs have turned out to be legitimate but I am also thinking one of the first things that anyone who is having wonky behavior with prior firmware presets should try is the procedure below. There have been some previous firmware versions where this seemed to help a lot of people.

 

I know that the Helix is supposed to handle an "upgrade in place" for prior firmware setlists/presets identically to reloading them afterwards but I am not absolutely sure it is. Has this notion crossed anybody else's mind? I think it also may have something to do with exactly what blocks, routes, and settings were used in each individuals former presets. Some may be more problematic for upgrades than other.  Maybe reloading setlists from backups is handled differently in certain circumstances than just leaving them in place for the firmware upgrade process. It seems like maybe more than a few people have had issues go away after explicitly reloading their backups. I suppose it could also have something to do with how closely they adhered to Line6's upgrade procedure or whether they had any bumps in the road while upgrading.

 

Lastly there is always the possibility that both methods, "upgrade in place" or reloading from backup, miss something in translation and the only method available to fix certain presets, at least until a later firmware update, is to rebuild them from scratch.

  1. Make sure you have at least two sets of good backups of your old setllists!!!!  I would save the setlists and/or presets individually as well as doing a "Create Backup".  If you have good backups from a firmware version before 2.80 you may want to try restoring those instead of the ones that are potentially already corrupted in 2.80.
  2. Run the global reset procedure (get the new Factory and Template setlists if desired).
  3. Restore your user presets, either from HX Edit menu's 'File'--> "Restore From Backup" process or one setlist at a time.

 

Line6 if this post is incorrect please chime in. Obviously I have no actual technical insight as to whether there actually is a difference in processing of legacy presets by the upgrade process versus reloading them.

Share this post


Link to post
Share on other sites

Ok ... having trouble and am scared ! 

I did a successful backup of my 2.71 and know where it is. 

I have updated my HX edit to 2.80.  HX Edit tries to connect to my Helix Floor and then reads "connection interrupted". 

My Helix floor reads  "Boot Failure,Entered Update Mode". 

I am stalled and at an impasse apparently ....

 

Please Advise !

Share this post


Link to post
Share on other sites

I think I need to restore my Helix to factory reset and install my backup to be a ble to start the update again ... but , I seem unable to do this.  How do I get my Helix off of the current “boot Faiure, Entered Update Mode” screen ??  Until I can , I seem unable to use the backup utilities in HX Edit.

Share this post


Link to post
Share on other sites

I performed 2.8 update according to instructions on my Stomp - it went flawlessly and improvements are great!

My only question is - is there a way to reload the custom presets I created in 2.7? (I did perform backup prior to update)

 

Thank you

Share this post


Link to post
Share on other sites

Hey Guys!

 

So I was doing the update to 2.80 today and updated my line 6 installer and then clicked to update to 2.80. My power went out and now I have an updated helix edit but my helix floor is stuck in the boot failure AND there is nothing in the Installer to download to start over. I have been in this mode for 25 minutes. I don't know what to do to get it working. Suggestions?

Share this post


Link to post
Share on other sites
1 hour ago, rockinb said:

I think I need to restore my Helix to factory reset and install my backup to be a ble to start the update again ... but , I seem unable to do this.  How do I get my Helix off of the current “boot Faiure, Entered Update Mode” screen ??  Until I can , I seem unable to use the backup utilities in HX Edit.

 

This stuff is available all over this site, there is even a big black circle containing a question mark in the bottom right hand corner of this page where you can find a link for the hardware reset procedures.

 

If you look a bit further on this forum you will find stacks of posts along the lines of “firmware 2.80 bricked my Helix”, “Boot failure” etc. 

 

Seek and ye shall find - plus it saves me having to type all this stuff out over and over again. Try this one for clues.

 

https://line6.com/support/topic/49049-helix-lt-280-update-problems/?tab=comments#comment-305283

 

Here ya go - try Safe Boot and run your Updater again.

 

Reset Options

 Helix Floor/LT

Button Combination Description
2 LED light Fun
3 & 4 Test Mode
5 & 6 Global reset
7 & 8 Reset setlists to factory, Keep IRs
8 & 9 Reset setlists to factory, Clear IRs
9 & 10 Reset setlists to factory, Global reset, Clear IRs
10 & 11 Upgrades existing presets to latest format
11 & 12 Clear current preset
5 & 12 Clear setlists, clear IRs, Return system settings to default
6 & 12 Safe boot mode

To use Reset Options:

  • Power off the Helix
  • Hold the desired button combination
  • Power on the Helix
  • Release the button combination

Please note: Buttons are numbered from top left to bottom right.

Share this post


Link to post
Share on other sites
42 minutes ago, dannyfast said:

Hey Guys!

 

So I was doing the update to 2.80 today and updated my line 6 installer and then clicked to update to 2.80. My power went out and now I have an updated helix edit but my helix floor is stuck in the boot failure AND there is nothing in the Installer to download to start over. I have been in this mode for 25 minutes. I don't know what to do to get it working. Suggestions?

 

^^^^^THIS^^^^^

See post above

Share this post


Link to post
Share on other sites
1 hour ago, glennsong said:

I performed 2.8 update according to instructions on my Stomp - it went flawlessly and improvements are great!

My only question is - is there a way to reload the custom presets I created in 2.7? (I did perform backup prior to update)

 

Thank you

 

Hi,

 

Yes, that I’d what HX Edit is for. It allows you to backup, edit and restore your custom presets. Load them into HX Edit, connect to your Stomp with USB and transfer your patches across.

 

What baffles me is you said that you made a back up prior to updating, so you must be familiar with this process.

 

Unless I am missing the point somewhere?

Share this post


Link to post
Share on other sites

I believe my issue might be that I backed up my stomp - I did not export presets - back up now greyed out

Share this post


Link to post
Share on other sites
19 minutes ago, glennsong said:

I believe my issue might be that I backed up my stomp - I did not export presets - back up now greyed out

 

Confused!

 

If you “backed up” your Stomp you must have done that with HX Edit - there is no other way.

 

If you made a complete back up with HX Edit you use that to restore your custom presets. From under the menu there will be the option to restore presets, IRs etc. Also if you click on that little gear wheel in the bottom left of the HX Edit screen that should also reveal a way to reload your backup.

 

if you think you backed up using any other method then... oops! You just made a mistake that you will never do again.

Share this post


Link to post
Share on other sites

yes I did use HXE - I got this right before upgrade and new to the interface - thank you for your help!

  • Thanks 1

Share this post


Link to post
Share on other sites

Ok ... having trouble and am scared ! 

I did a successful backup of my 2.71 and know where it is. 

I have updated my HX edit to 2.80.  HX Edit tries to connect to my Helix Floor and then reads "connection interrupted". 

My Helix floor reads  "Boot Failure,Entered Update Mode". 

I am stalled and at an impasse apparently ....

 

Please Advise !

Share this post


Link to post
Share on other sites

Sorry for the repost ....

 

Hey DataCommmando .... thx for the tips ...

 

I did the safe reboot and re-ran my updater ...the Line6 updater says update in progress , don't turn off etc. ... my Helix floor says "Ëntered Update Mode" but I see no progress on the Firmware installing line on the updater page ....  any thots ??

Share this post


Link to post
Share on other sites

when my Helix floor reboots it shows on screen version 2.80 for a second before going to the entered update mode"  screenshot...

 

now, i keep getting "üpdate failed messages, please try again" on both the helix floor and in the line 6 updater screen ...!!

 

How can I go back to 2.71 and recover backup ?  Load HX edit 2.71 first ?  then the 2.71 firmware ?

Share this post


Link to post
Share on other sites
12 hours ago, rockinb said:

when my Helix floor reboots it shows on screen version 2.80 for a second before going to the entered update mode"  screenshot...

 

now, i keep getting "üpdate failed messages, please try again" on both the helix floor and in the line 6 updater screen ...!!

 

How can I go back to 2.71 and recover backup ?  Load HX edit 2.71 first ?  then the 2.71 firmware ?

 

Hi,

 

Apologies for delayed response, but sometimes I feel it’s necessary to eat and sleep.

 

O.K. If you want to regress to 2.71 it should be straight forward. First you need to clear the “update failed” status from the hardware. I would suggest that you perform the “Safe Boot” routine again which will put your Helix in a state ready to accept firmware. Next, while connected to Helix with a good USB link open the Line 6 Updater application (the latest one should be fine). When it establishes a connection with your hardware, you should see a dark green screen which shows the available firmware. Simply select v2.71 from the list and perform the installation. Of course, you need to be connected to the internet to do this and make sure that during the installation process your computer doesn’t go to sleep or have any other programmes open that may interfere. So, no music streaming and no other Line 6 software running in the background.

 

Give it a shot - good luck.

Share this post


Link to post
Share on other sites

Hey guys .... i appreciate what help i got. 

 

i tried every combination of updates, cords, ports, restarts, safe boots for the last 36 hours ... although i don't know why ... i finally was able to get the 2.80 updater to recognize my helix ; after many attempts to reload version 2.71 that failed ... i finally got one to go through and restore my unit to 2.71. 

 

all of my presets. snapshots, and settings relaoded automatically.  i did not have to restore my backup with HXEdit. .... not sure why ..  but glad for it !!

 

Future updates will have to be bullet proof for me to try this again .. !!

  • Thanks 1

Share this post


Link to post
Share on other sites

So, after reading around on the forum, I'm noticing a lot of people had the same issue I did.  I figured I would post the solution.  My install stalled at the midpoint like most of the others having issues on here.  It was then that I decided to read ALL the instructions.  After reading around on the forum I saw a lot of people were in the same boat.  I realized I missed a critical piece of information.  TO INSTALL HX EDIT UPDATE BEFORE RUNNING THE FW UPDATE.  So, I had to do it while it was stalled.  At the end it said I needed a reboot, and I was worried, but what I ended up doing was just closing everything out except the installer, leaving the Helix LT on, and on the error message screen.  Once the computer rebooted, I re-ran the updater.  It actually didn't even do the first half of the install over.  It just continued on with stall point were it left off, and I'm now happy and jamming again.  Hope this helps someone not make the same stupid mistake.  But if they do, at least they can fix it without the fear I felt!  Most likely you either made the same mistake, or you didn't reboot your PC after running the HX Edit update.  Which would be why your PC's are not recognizing the device also.  It's because the 2.8 driver has not been properly engaged yet.  Good luck!

Share this post


Link to post
Share on other sites
On 8/3/2019 at 8:00 PM, takeaimnfire said:

....My install stalled at the midpoint like most of the others having issues on here.  It was then that I decided to read ALL the instructions.  After reading around on the forum I saw a lot of people were in the same boat.  I realized I missed a critical piece of information.  TO INSTALL HX EDIT UPDATE BEFORE RUNNING THE FW UPDATE.  ...

 

I think failing to install the latest version of HX Edit first (it also installs the latest drivers and Updater) is probably the single greatest cause of failed updates.

Share this post


Link to post
Share on other sites

I note that the update instructions state, "Open YOUR CURRENT VERSION of HX Edit (NOT the new HX Edit 2.80)."

 

Well I'm installing on a new computer. Should I install an older version of HX Edit to do backup before I install 2.80?

 

Thanks

 

Simon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×