Jump to content

Line 6 Software gone downhill?


quackerjeff
 Share

Recommended Posts

I have a PodXt Live and a JTV-69.  Both really nice pieces of equipment!!  However, I'm stuck with what's on them because I'm a Mac user and upgraded to High Sierra.  Line 6 Edit for editing and saving my channel banks requires Java6 and even if you install it, High Sierra will start going bonkers with Java AWT errors when using it.  What else can I use to manage/backup/edit my Pod Xt Live?  Now, when it comes to Workbench HD, sure it all looks like it will work, but when it first starts up, it times out trying to download the presets.  When I try to change body style or make some other change, it just freezes.  This happens on multiple computers, one running Sierra and the other High Sierra.  It just seems like the software quality and support has gone downhill.  I can't make any changes to either pieces of equipment.  Heck, I even tried on someone's Windows 10 machine and Workbench did the exact same thing, and I couldn't even get Line 6 Edit installed on it.  

 

To Line 6:  Look, your equipment is great, it lasts a REALLY long time.  But, you just can't forsake software when the operating systems advance.  If you don't see it being cost beneficial to do so, then open up the software and allow the open source community to manage it.  I spent my entire holiday trying to edit/customize my equipment settings and got absolutely nowhere.

 

Any advice from out there in the ether?  Any similar experiences?

Link to comment
Share on other sites

Similar issues here.  I've been using L6 gear for over 12 years.  POD XTLive, Variax 500, GX, DT50 212 Amp, HD500, JTV59.

 

Monkey & Licence Manager doesn't work on my iMac running High Sierra 10.13.

 

L6 Updater only shows a blank, black screen asking for which device to update, but none are shown. Cannot find a solution via the User Fora, nor does theL6 'knowledge base' help. Every piece of L6 software I start, besides Updater, "This app is not optimised for your Mac.  It needs to be improved by its developer..." etc.  Several apps (Monkey & Licence Manager) won't run at all.

 

When the L6 stuff dies from here on I will never replace it with L6 gear again.

Link to comment
Share on other sites

Seems like it was worded incorrectly. 

You upgraded everything. L6 changed nothing. L6 software hasn't gone downhill, it remained the same. Proper writing would have been, L6 software remains stagnant, while others go uphill.

 

Link to comment
Share on other sites

@pianoguyy You are so correct.  Let me also state that this is a testament to the quality of their hardware.  It is superb and IMHO is second to none.  The fact that I have their hardware working FLAWLESSY for over 10 years speaks volumes.  I have no need to upgrade because it does what I want and when I want.  I guess if they make hardware to withstand the tests of time, I just thought it would make sense for them to do the same with their software.

 

@cruisinon2 I was able to finally get my Workbench working, it was that with the new version of the software, I must use the Variax USB dongle, whereas before I was just able to access my Variax via my POD Xt Live interface.  Seeing that it isn't USB 3.0 compatible, that is the reason I was seeing timeout issues. 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...