Jump to content
BotSkittle

Possible bug with HX Effects?

Recommended Posts

Hey all,

 

Recently, I was noticing some odd behavior with my HX footswitches during live use. If I went to engage an effect by stomping on the footswitch, it would turn on, but after maybe 1-2 seconds, it would bring up the screen that allows you to edit parameters of that selected effect, and I would have to press the MODE/EXIT button to return to the stompbox layout. This would happen intermittently, but eventually, I got fed up and checked to see if I was behind a firmware update, and I was.

 

Without issue, I upgraded both the HX Edit software AND the HX firmware to the latest version. I did not see my specific issue listed on the bug fixes, but I was still hopeful it would resolve my issue.

 

At first, it seemed like the update did the trick, but after a little more fiddling with my setup, a new problem arose, but still quite similar to what was happening before. This time, though, instead of bringing up the screen to edit effect parameters, it acts as if I am soft-touching two effects to engage the "swap footswitches" feature. See the video below, demonstrating the issue.

 

 

 

As you can see, I'm not using the soft-touch feature at all - simply turning effects on and off in "stompbox" mode with a normal pressure used in a live setting. My brother also has an HX and I showed him the problem, and we could not replicate the problem with his unit in the same signal chain, same room, same power, etc.

 

Do I have a faulty unit? In the meantime, or regardless, is there some way to disable the soft-touch feature on the HX? Honestly, after using the unit for the past 2-3 months, I have never really used the soft-touch features.

 

Thanks for any advice or support, folks.

 

Share this post


Link to post
Share on other sites

I've not had this issue with my HX unit...And must say If I did it would drive me up the wall. It's like the unit thinks you have made an edit to a block.

Share this post


Link to post
Share on other sites

Try this to see if it stops it from happening....

Global Settings > Switches > Stomp Select (set this from "touch" to "press")

 

If this alleviates the problem, it's the capacitive switches that are too sensitive. It may be your unit, it may be your environment. My switches don't do what yours is, but I do find them too sensitive for a live setting so I always turn that feature off (ie: set it to "press") unless I am editing the unit.

 

7 hours ago, BotSkittle said:

My brother also has an HX and I showed him the problem, and we could replicate the problem with his unit in the same signal chain, same room, same power, etc.

 

Is this right, you COULD replicate the problem under those conditions on a different unit? That would indicate the environment to me, not necessarily a faulty unit. I would suggest you try your unit in many different environments to see how it responds. 

 

Share this post


Link to post
Share on other sites

@codamedia Thanks for the suggestion. I will give it a shot and see what happens.

 

And I edited my post accordingly, my bad. We could NOT replicate the problem. It was only with my unit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×