Jump to content
SuicyanidePillz

Spider 3 HD150 powers off and on by itself

Recommended Posts

I just bought a used Line 6 Spider 3 HD150 head from Guitar Center. I powered it up and started to play (through headphones as I do not yet have the cab for it) and it worked fine for about 30 seconds. I looked down at my FBX longboard and noticed that it had switched banks by itself from Bank 2 to Bank 3. I switched it back to Bank 2 and the preset channel I was using, then the sound cut out. After 2 seconds it came back. Then it started doing it over and over. I noticed it was actually powering off and on repeatedly. Any advice on steps I should take to correct the issue? I have 45 days to return it if I can't fix it. Thanks in advance.

Share this post


Link to post
Share on other sites

Should never turn on without speakers plugged in, might have blown an amp chip.

If it's power cycling, then it needs to be checked out by a Line 6 authorized service center.

 

  • Sad 1

Share this post


Link to post
Share on other sites

Hopefully the amp chip is still intact, but the power cycling would be a program

board thing that would have to be done by service tech who knows the product.

 

Uuuh,... long haul.

 

Share this post


Link to post
Share on other sites

Ok. I'm back. I exchanged the above mentioned amp for another, also a spider 3 hd150. I have the cab and everything set up. 

 

This one is power cycling as well! Any idea why? I am running the spider 3 with the 412 slant cab, 2 3ft 12 gauge speaker cables, and an FBX longboard.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×