Jump to content

Cannot Install HD300 driver using Win10 64-bit. POD HD300 Editor displays "No Line 6 device connected".

Recommended Posts

I was able to use the Line 6 Monkey v1.77 and after installing the driver still it show's, no driver was installed.


I hope someone can help me here. I already reviewed other forums.

I am currently using Win 10 64 bit.

Dell Optiplex 9020 with i5 4th Gen processor.



Share this post

Link to post
Share on other sites

We'll, additional troubleshooting done:

- tried it on a Dell netbook with Win10 32-bit (won't detect);

- bought a new USB cable (still);

- restore to factory settings (the usual);

- tried using the Administrator account (the same);

- used the compatibility troubleshooter of Win 10 (no go);


Even if i'm going to reinstall the driver a million times, it would still say "No Devices Connected".

Additional findings in the control panel items: (device is on; USB cable is connected)



Hopefully somebody could help me on this.

Share this post

Link to post
Share on other sites



Try to install drivers manually, open device manager, select your hd device, click properties and update drivers, select manualy folder with drivers (x64 ver.) and click update.

Share this post

Link to post
Share on other sites

Hi kryhan,


I can't manually install the drivers via Device Manager as the Line 6 POD 300 cannot be detected. There's no unknown device or whatsoever that exists in the DM.

I have actually bought an HD 500 recently, and it was detected on the same PC that i am using. No problem/issues at all. I don't know anymore, it could be a hardware issue that needs to be serviced. :( 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now