Jump to content
Sign in to follow this  
carlito17

G70 back to G50?

Recommended Posts

Has anyone switched back to a G50 after using the G70?

 

I was an old X2 user. Then I switched to the G90. A few years ago I switched to the G70 so I could shrink my rig down. Ive has most of the same problems everyone else here mentions. Dropouts, dropouts, dropouts. I’ve also powered mine up and all of my saved presets were gone. Twice in 2 years. Names, routing, etc. All gone. Luckily once was at a soundcheck so I could fix the problem and the other was at a rehearsal.

 

It doesn’t seem as if anything can be done about it so I’m considering going to a G50. Has anyone done that? If so, are the new G50s as glitchy as the G70.

 

This isn’t a bash Line 6 Thing. I actually dig Line 6 stuff. I run a Helix rack and even have a couple of old M5s. Unfortunately the G70 seems like a turd in the line from everything I’ve read.

Share this post


Link to post
Share on other sites

New firmware is out. Try that.

Also, make sure your patch cable from the guitar to the transmitter is not the issue. I had a bad one that shipped with my G70 that caused dropouts, and I swapped it out for another patch cable and it worked fine. Then I contacted Line6 and they sent me a replacement. A new locking cable for the G70 is $19.99, FYI.

Share this post


Link to post
Share on other sites

I was using a G50 for a while but swapped to the G10 to get rid of the belt pack. What a mistake. The G50 was solid as a rock and you manually select a known free channel. Initially the G10 worked well but after a couple of months it fell in love with the drummers IEM channel and I can't use it now.  I've been looking for a G70 as our there Guitarist uses one, and he's never had any drop outs and we run a lot of wireless. 3 mics, 1 Bass, 1 Guitar, iPad for TF1, and second iPad for ADJ wifi DMX, 2 x IEM systems. G70 has disappeared in Europe now as something in it upset the Germans ,and they reckon it will be 2020 before its reincarnation appears! Looks like I'll be buying another G50 as being tied is a bit of a pain!!

Share this post


Link to post
Share on other sites

Hi saw your post and I've been using the G75 and TB516G transmitters for a few years now. The set up usually works pretty well but last weekend I did start getting drop outs again. I went looking for firmware updates and there hasnt been anything since 2015. Are you happy now with the G50 ? Any dropouts with that system ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...