Jump to content

Usb Device Not Recognized


Andstev
 Share

Recommended Posts

  • 3 years later...

Same for me, can't recognize the pod and frozen on the logo... I tried everything with the arrow key, down, right, left, flash position update flash etc... reboot reinstall drivers different pcs mac everything.. This product is really a piece of crap.

Link to comment
Share on other sites

  • 1 month later...
  • 5 months later...

USB port does not recognize the pod hd500x. I have an iMAC with mac os high sierra v 10.13.14

I`ve tried all the USB ports on the MAc and it does not work, the ports with other equipment work perfectly.
Is it because of USB 3?

Already when plugged into win10 everything works perfectly.
Can someone tell me what I need to do to work on MAC

Thanks a lot

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...