Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Main Out Volume Knob Issues On M20d

Recommended Posts

Try Reloading the firmware update..... I have not ever had this problem. What I do notice with mine is if I turn it slow it takes a long time for it to turn off because it is in very small increments if you turn it quite fast it will jump the volume up much quicker.

Link to comment
Share on other sites

Computers are not the same as this type of hardware, and i've witnessed this very action correct a number of issues.

it's easy enough to try... and works SOMETIMES... so why not give it a shot if it might help?


I dont see how peopel think reloadign the firmware fixs a issue. I work on pc hardware for a living and a firmware update yes that fixs issues. but reloading the same firmware? never . unless its because it resets the defaults of the bios

Link to comment
Share on other sites

I haven't had any issues on mine and I've owned it since Aug 2012, but I was in 2 different music stores today and both demo models had a problem with the volume knob. The 1st one in SamAsh had older firmware and it got stuck very low and went back and forth and I had to press the wheel down hard to make the volume go up and the 2nd at GC had  the newer 1.2 update and wasn't as bad. The 2nd one was on sale for $1300 - still a great deal!  I also have 3 older emu keyboard modules that also have had issues with their data knobs and emu did sell replacements for theirs.  -maybe Line 6 should go down to SamAsh in hollywood and check it out.

Link to comment
Share on other sites

I have to agree with bassforlife2013. I design embedded hardware for a living.


If the m20d were suffering from bad firmware updates, there would be complaints of dead and even possibly bricked m20d units on the forum here. 


There is an infinitesimal chance that a firmware loading issue would result in the same encoder shaft bug every time a firmware update went bad. 


There's also very little chance that there is no error checking of the firmware when loaded.

The industry standard is to first check the new flash file is good, 

then load it into a clean erased flash location,

then check that the new flash programming worked via checksum(s),

then change the boot loader to aim at the new verified flash image. 


If at any point something goes wrong, it would just keep the previous flash version running,

or in some cases, run a permanent "safe recovery image" that can be used to retry the programming of a new image. 


If the firmware doesn't load properly this almost always results in a complete failure to boot, not a tiny (but important) feature acting a little strange.


Updating the m20d firmware is really no different than updating a PC motherboard flash rom update, or cellphone rom update etc. 


I too see the same bug by the way. Spin too fast and the volume can go backwards. This means some math errors at the shaft encoder logic. 

It probably means the m20d can't keep up with the volume knob messages quickly enough when the user spins it too quickly.


I do notice the m20d gets laggy once in a while, then seems to get back to normal.. 

  • Upvote 1
Link to comment
Share on other sites

This is a hardware issue. Our customer service can help you to resolve this.


The US support team can be reached at 818-575-3600 (option 2), Mon-Fri 8am - 5 pm PST. Our busiest hours are from 11am to 2 pm.


The UK support team can be reached at +44 (0) 1788 566 555, Mon-Thurs 9am – 5pm GMT and Fri 9am – 4pm GMT.

Link to comment
Share on other sites got off the phone with the fine folks at The US support team. Apparently this is NOT a hardware issue. The encoder is designed this only operates at a fixed rate of speed. If you spin the wheel too will act erratically. Must try it at a slower speed when I get home to see if it works as it should. I thought it started happening after I did the update but I guess I only just noticed it at that time...(Still think something funky is

Link to comment
Share on other sites

Hi...I did test last night with different scenes/setups but with the same result. If I turn it dead works half decent but not like it should...I think it may be time for another call...They tell me that it is designed to only work at a certain rate of speed so that users will not accidentally turn it to max. I just don't recall it ever doing that before the update...

Link to comment
Share on other sites

  • 2 years later...
  • 2 years later...

Same here as with dawson60. I always use an ipad for remote operation since this error occurred, but this is not a good solution for such an expensive equipment.

I will contact line 6 support as propsed by ArneLine6 in 2013. I  hope they will have a solution.

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Hy everybody....


i Had long Time Problemes with the Master Volume Encoder...

i had to use it slowly otherwise it jumps all the time... i was disapointed...

Today after looking at Youtube how to open a Encoder.. it doesnot matter for a Amplifier for exemple...

i Opened the Encoder very carefuly and cleaned it with alcohol ( ysopropanol 70 % )

I closed it back and wonder ..... It works perfect...

now i can use it very fast... it works perfect...

Sorry for my english, i am from Germany



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...