Jump to content
johnmackenzie

Cannot record dry track via USB in ProTools with Helix

Recommended Posts

Hello, I cannot seem to get the dry tracking option working in ProTools with my Helix. I've tried reading the Helix manual, looking through Helix posts, ProTools posts and any videos I can find but nothing so far. Here is what I have set up:

In Helix I have:

  • USB connected to Windows 10 PC
  • in Global Settings I have USB In 1/2 set to Multi
  • In the patch I have output set to Multi

In ProTools I have:

  • Playback Engine set to Helix
  • I/O is reset to default with the Helix settings that populate automatically
  • Tried mono track set to input 7 as well as input 8 and get no audio
  • Tried stereo track set to input 7/8 and have no audio

In Windows I have:

  • Audio device to recording and playback set to Helix

If I select input 1 I can record the processed track fine...no issues, but I cannot get the dry track to record. This is my first time trying this as I have always recorded the XLR out of Helix into my Focusrite interface. I wanted to try recording a dry track so I can use Helix Native to process the sound.

 

Can anyone help?

 

Thanks in advance!

Share this post


Link to post
Share on other sites

You also need to set the re-amp source. This is the part of the manual you want:

Quote

Recording a Dry DI Track

For this example, we'll record guitar into two DAW tracks simultaneously, with one capturing the Helix-processed tone and the other the unprocessed DI guitar.

1. In the Helix Global Settings>Ins/Outs>Page 3 screen, set Re-amp Src (USB 7) to "Guitar" (as shown above).

2. Dial in your desired Helix tone, while keeping the Helix Input and Output blocks both set to the default "Multi" setting.

3. Create two new audio tracks in your DAW software project:

Create one mono track to record the dry DI guitar, and set the track's input to Helix USB 7.

Create one stereo track to record your full, stereo Helix-processed tone and set the track's input to Helix USB 1/2.

4. Set both tracks' outputs, as well as the DAW Master output, to Helix USB 1/2 to allow all tracks to play back through Helix. NOTE: Setting the stereo track's output to Helix USB 1/2 allows you to hear your Helix-processed tone via the Helix hardware monitoring while recording. For this configuration, disable software monitoring on all DAW tracks.

5. Arm both these DAW audio tracks, hit the Record button and start laying down your guitar performance! Now you have your Helix-processed track to hear with the project, and a separate DI track with which you can further experiment at any time with DAW plug-ins and/or reamping (see the next section).

 

  • Haha 1

Share this post


Link to post
Share on other sites

Thank you so much!!! I feel like an idiot. I had it set to guitar and thought that was correct but.... I was using my Variax! Problem solved!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...