Jump to content
elDeadache

HD500X - how can I get rid of its output from the mix while using plugins?

Recommended Posts

Hi guys,

I want to use plugins like e.g. Helix Native or Bias Amp with my HD500X. But when I set it as an input/output in a plugin, I can only get a mix of both outputs (plugin + HD500X). Is there a way to get output only from the plugin, either by itself or with help of a DAW or whatever else?

Thank you for your time and attention.

Share this post


Link to post
Share on other sites

Are you trying to have a guitar feed going through the POD and also through Helix Native? In parallel or are you trying add more FX to the signal chain that you are using the plugin and POD? 

A more clear plan would help for us to give our 2 cents. 

 

Jd

Share this post


Link to post
Share on other sites
20 hours ago, jakeman19 said:

Are you trying to have a guitar feed going through the POD and also through Helix Native? In parallel or are you trying add more FX to the signal chain that you are using the plugin and POD? 

A more clear plan would help for us to give our 2 cents. 

 

Jd

 

I want to use POD only as a connector between my guitar and the computer, and then my computer and speakers connected to POD. The problem is that I hear too much in the speakers at the same time: original POD output + POD output affected by the plugin. I don't want the original POD output when I use plugins. After heavy googling, I eventually found out yesterday about a possibility to turn off hardware monitoring in "Line 6 Audio Midi Devices". It kind of does the job for standalone plugins (effects from POD still affect the sound, though, but I can live with that as I no longer hear the original POD output in my speakers and I can turn off effects on the POD). So the issue appears to be solved for standalone plugins. But it doesn't solve my issue when using plugins in DAW, I still have the original POD output there. I will try to do more testing tomorrow, as I didn't have time to check everything in the DAW properly, but I suspect I won't solve that issue this way. I suspect that the original POD output will be leaking into the recording, too, but I didn't get to check it so far so it's only a suspicion. So if you have any advices to give before I go back to testing, it will be appreciated. Maybe there is something more in POD settings that I'm missing?

Share this post


Link to post
Share on other sites

I'm having the same problem. The HD500 can be used as input source but not for monitoring as you'll hear both the Pod sound AND the vst. There has to be a setting in the Pod to turn off the direct monitoring but there isn't so it's useless for that.

Share this post


Link to post
Share on other sites

I actually have the same issue.  I was wanting to test the Helix software running from my Macbook pro using my HD500x as an interface for both input and output.  However, I'm not confident I can do this because I run into this issue using plugins in Garageband.  Currently, I'm using a "dry" patch to feed into my macbook to be processed by plugins I run in GarageBand.  However when I do this and attempt to feed the 1/4 output of my HD500x to a monitor, I get both an affected signal and a dry signal.  Same thing happens when I use the headphone output on the HD500x.  However, when I use the headphone output of my Mac, I get only the affected signal, which is what I want.  I don't know why I can't shut off that dry signal in my HD500x.  I'm sure it's user error, but my googling hasn't found me an answer quite yet. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×