Jump to content
Sign in to follow this  
electricfactory

HELIX help sought, guitar cable tip stuck, help!

Recommended Posts

The tip of a guitar cable has left itself behind in the guitar input port, as a result I can't use it until I remove the tip of this cable( you can see it in the pic below).
Is it possible to use the AUX imput for guitar ? Anything special I have to do to make it work or are both inputs essentially the same ? Has anyone removed the back of their HELIX, anything special to know about removing the back panel to get at the jack ?
Thanks, appreciate any help.
 
aYznPZIl.jpg
 
HUBZu14l.jpg

Share this post


Link to post
Share on other sites

I had this problem not too long ago. You can use the aux in for guitar, but the impedance is much higher and as such is normally better for active/hot pickups. 

 

I got the tip of my cable out by screwing a long screw into the lodged tip so that it was stuck on the end of the screw, then simply pulling it out. 

 

It may take a few attempts as the clips are quite stiff, but it did work for me. Hope you get it out! 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...