Jump to content
drugboy

Serious issue after firmware update 2.7 not completed

Recommended Posts

Hi,

 

i am on windows 10. Firmware update 2.70 broke up and did not complete. Now my helix does not boot.

 

Screen says FW Version 2.70.0 but helix hangs and is not booting.

 

red "0" on top left, than changes in some red cryptic letters in the top line.

 

helix unit is not found by windows and helix edit 2.7

 

helix control is not recognized.

 

After entering update mode enc 1&6 helix is recognized by windows but helix edit can not connect - error message "connection interrupted"

 

Tried with PC and notebook - same issue.

 

Tried several usb Ports, cables etc. - same issue.

 

Driver is updated.

 

Can anyone help?

 

Thanks and sorry for my bad english

Thomas

 

 

Share this post


Link to post
Share on other sites

I agree with Rocco_Crocco.....contact Line 6 Support.  I'm sure your unit is just fine and they'll be able to help.

Share this post


Link to post
Share on other sites

I see you're trying to connect to HX Edit, but have you tried reconnecting to the Updater? I would download the FW separately and save it to your computer, then try running the Updater again and installing the FW from the hard drive instead of downloading it through the updater.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...