Jump to content

Firehawk Fx Problem


Recommended Posts

I just got the firehawk Fx last week because I decided to upgrade from my HD500X and I am faced with a tonne of problems since then. The set has been frozen over and over again. I tried all the possible solution I can find from the internet but the issue still persist.


The problems began with the freezing of the set with the A and C lights switched permanently on when I just took it out of the box and switched it on. I googled and I did a factory reset by holding the tone and master volume down. The set resets and it becomes 4 blinking lights from A to D. I did another check and it is now said that it is a failed update. I installed the drivers and line 6 updater on my computer. Then I hold down A and C while starting the set and got it to update mode and updated it to Version 1.30. Now it works well as it is said that corrupted tones are the cause of the problem (I don’t think so because it was like this even before I connected it to the remote app)


Well I give Line 6 the benefit of doubt. It now works well, managed to download 2 tones from the cloud library ensuring the tones were created using the latest firmware (I check the date to ensure it was created 2018) and set up my tones. I can’t find any other way to determine if the tone from the tone library is created with the latest firmware other than looking for the ‘updated date’ for the tone. 

Then comes the next problem I tried to download another tone and the machine freezes again with the A and D lights lock up. So this time I already know what is the problem I switched off and on and it works. So I thought until 5 minutes later it locks up again. I did a factory reset by holding the tone and master volume down again. The set resets and it becomes 4 blinking lights from A to D again (back to the first problem). I did the same thing and went to get it updated by reinstalling the V1.30 Patch but this is where it get totally different.


After reinstalling the patch the set resets and goes back to the 4 blinking lights. And I tried this with all the versions and it remains the same. And now I can do nothing about it. It is completely useless.


I am v disappointed with this machine. I have been using line 6 HD500X for over 4 years now with no problems whatsoever. But now when I upgraded to what was supposed to be an easier to use multieffect board, I get into so much problems. I hope there can be some form of rectification.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...