Jump to content
Sign in to follow this  
kazoue911

Helix USB stability

Recommended Posts

Hi all,

 

Just did the firmware update on my helix LT (2.70) and It now seems to have a stability issue when using Helix as an audio interface. Every half hour or so, the usb seems to disconnect for about a second or so and switchs back to the inboard sound card of the PC. It then reconnects as quickly as it has quit and works fine for another half hour approx. I was wondering if anyone had had this problem too? Helix is the only device connected via USB and if I don't use it as an interface (say I only use the midi over usb fuction) It works fine... I don't reject the PC being a possible cause for this problem but it didn't behave that way prior to update...

 

Thanks

Share this post


Link to post
Share on other sites

+1

 

same here.  It isn’t prevalent but certainly happens more.  In the past, I would experience this when the USB was plugged into an USB 3 port.  Once I moved it to an USB 2 port it never dropped.  Since the upgrade it has happened more but random enough I cannot find a pattern.

  • Like 1

Share this post


Link to post
Share on other sites

I will try a USB 2.0 port see if it helps. I also read somewhere that connecting Helix through the USB port of an apple keyboard had helped someone with a similar problem. I don't have such a keyboard handy but I tried using a USB extension cord with an active repeater and, so far, I hasn't let down on me. I only tested it for about 2 hours or so though. I'll keep tracking progress, more info to come...

Share this post


Link to post
Share on other sites

@prudenjim I might have found out what the problem is and a possible way to solve it. My setup goes as follow: PC usb to helix, helix xlr to m-audio BX5 (2x). All the mains connections share the same power strip. Turns out this perticular connection arrangement is very favourable to ground looping issues. I lifted the ground from the helix (push button next to XLR out) and so far, haven't had a disconnecting in 5 hours of playing or so. This setup has a particularly low noise floor so, no ground loop induced hum is actually audible, regardless of the state of the ground lift switch, but I think that the digital aspect of the Helix might get confused by interferences picked up through electronically "noisy" ground... Please let me know if you have the same results with your setup. good luck

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×