Jump to content
Sign in to follow this  
gsmccoy

JTV69 power-up problems

Recommended Posts

Been using this guitar without problems for several years.  Now suddenly, it will not power up with an external power supply.  It works okay with the battery.  I have tried two different JTV power supplies (both the switching unit and the DC power units), and I have tried to power it with my old HD500, using the Variax cable.  None of these will power the guitar.  I am stuck with the battery, which is ok, but having no back-up leaves me vulnerable.

 

I have tried this:  I inserted a 1/4" plug into the guitar and turned it on with battery power.  Guitar comes on.  As soon as I plug the other end of the cable into the JTV power supply, the guitar shuts off.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Does the guitar cable have TRS (tip/ring/sleeve) connector ends?

 

Also, being an older guitar in the bunch, it may need the guitar equivalent of

a 50,000 mile check up.

 

Share this post


Link to post
Share on other sites
1 hour ago, psarkissian said:

Does the guitar cable have TRS (tip/ring/sleeve) connector ends?

 

Yes.  I have tried several, in order to eliminate cable failure.

1 hour ago, psarkissian said:

 

Also, being an older guitar in the bunch, it may need the guitar equivalent of

a 50,000 mile check up.

 

I'm afraid this is a probability.

1 hour ago, psarkissian said:

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×