Jump to content
slaughlin1103

Helix Help

Recommended Posts

Just picked up a Helix FL and PowerCab Pro and having problems with dirty and high gain amps.

None of the Dirty factory amps and anything I’ve downloaded from custom tone sounds real. All have a buzz and fake tone.

Did I miss something in set up.

 

thanks

Share this post


Link to post
Share on other sites

Can't speak of the Powercab, but the first thing to do is to eliminate the Helix as the problem by using it with headphones or with studio monitors.

If that checks out, either someone here will help out, or you can try the Powercab and Helix  threads in the Digital and Modeling section on Gearpage.

Share this post


Link to post
Share on other sites

1) In your patches on the Helix are you using cab modelling?

2) On the powercab are you using speaker modelling or did you opt to use it as an FRFR?

 

With those two answers I can help.

 

Lewis

Share this post


Link to post
Share on other sites
9 hours ago, slaughlin1103 said:

Just picked up a Helix FL and PowerCab Pro and having problems with dirty and high gain amps.

None of the Dirty factory amps and anything I’ve downloaded from custom tone sounds real. All have a buzz and fake tone.

Did I miss something in set up.

 

thanks

 

Hi,

 

Re: Dialing in Power Cab

 

If you haven’t already done it, then I suggest you take a half hour and watch this video from Jason Sadites. 

Jason is a bit of a guru when it comes to setting up your gear to get the best out of it, of course YMMV!

 

Hope this is some assistance in your quest.

 

 

Share this post


Link to post
Share on other sites

Headphones are a great idea thanks. Have headphone but no adapter so just ordered on Amazon as I am not that thrilled with going out shopping this time of year. Will check out Friday when they come in.

 

I was using whatever the Factory 1 & 2 patches had. Also had a few patches from Glen Delaune and those with IRs seem to give me the same problem as the Factory tones. His patches without IRs were amazing but get  real buzzing fake sounding with IRs.

I have been using the FRFR on the power cab.

 

Going to watch video as I leave work.

 

 

Thanks to all for your help, hoping i'm just missing something in setup.

Share this post


Link to post
Share on other sites

If you're new to modeling, the learning curve is usually a bit steep, regardless of the devices in question. You can't think of any FRFR rig as a guitar amp... they have a far wider frequency response, and most throw sound around in a very different dispersal pattern than guitar speakers do, which are typically very directional. Listening to a guitar cabinet way off- axis is a very different experience than monitoring with FRFR.

 

For most applications, the use of low and high cut filters is more or less a necessity... to varying degrees depending on the amp model,  mic choice, clean vs dirty tones,  etc. etc. The need to cut frequencies you don't want to hear tends to become more pronounced as gain increases. 

Share this post


Link to post
Share on other sites

How you use the powercab all depends on what you want to achieve. If you want to achieve 'Amp in the room' then the standard approach would be:

  • Helix - Amp models, no cabs!
  • Powercab - use the appropriate speaker model for the amp you have chosen

 

If you want to achieve a 'Mic'ed up sound' then the standard approach would be:

  • Helix - Amp with cab modelling, you will need to set some hi and lo cuts on the sounds to remove fizz and low rumble
  • Powercab - use the flat mode with the FRFR voicing to reproduce the sound correctly
  • Upvote 1

Share this post


Link to post
Share on other sites

Hey Guys, just tried using headphones as suggested and that sound is not coming through to the power cab.

The sounds through the headphones are  much  better and some patches could use a littlie tweaking where without headphone were not usable.

My goal for now was to use the FR only on the powercab plus with all coming from the Helix.

Is this something in my global setting , the patches or could I have a faulty PowerCab Plus.

 

Thanks to all for your help...much appreciated.

Share this post


Link to post
Share on other sites

Sorry Lewis just noticed this..bad week!
1) In your patches on the Helix are you using cab modelling?  Downloaded Glen Delaune and Fremen patches.

Can see were Glen has cabinets used not sure with Fremen.  

2) On the powercab are you using speaker modelling or did you opt to use it as an FRFR?

I have the power cab set to Flat, that's FRFR right?

Just want to use Flat on power cab and use those patches. Do I need to set something up to do this?

With those two answers I can help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...