Please ensure Javascript is enabled for purposes of website accessibility Jump to content

USB error device not recognized


Recommended Posts

Trying to update some patches this morning on my Helix and I get a "USB error device not recognized message." Have tried several different cables, tried on both my desktop and laptop, same thing. Please help. Win 10, firmware 2.70, Helix edit 2.71.

Link to comment
Share on other sites

34 minutes ago, spikey said:

Hook up something else on that same cable/usb port. See if it links up ok. 

No problem reading the thumb drive that came with the Helix, or an SSD adapter.


Do I need to do a factory reset on the Helix?

Link to comment
Share on other sites

34 minutes ago, foxmeister said:

I see you are on HX Edit 2.71, but only on 2.70 for the firmware. I wouldn't have thought this would have made a difference, but have you tried running the L6 Updater to see if that sees your Helix and offers you the update to 2.71?

Can't run the updater because of the USB "device not recognized" error.

Link to comment
Share on other sites

I've only been able to load firmware ( and get the computer to recognize the HX effects) using the holding right arrow to put unit in fail-safe mode-- #5 below.


HX Effects resets


1. Holding FS3 + MODE - Will clear all Presets and IRs
2. Holding FS4+FS5 - Will reset Global Settings
3. Holding FS5+FS6 - Will reset Presets only
4. Holding FS6+TAP - Will Perform factory restore (reset, Globals, IRs, and Presets)
5. Holding the right arrow ">" Will put the unit in a fail safe update mode. Use this when the HX Effects is in a un recoverable state



Link to comment
Share on other sites

  • 8 months later...

I have met similar issue before, and my method is to update the Motherboard’s Chipset Driver , here are the steps, hope can also help you.
Step 1: Go to the Motherboard’s manufacturer website and find the latest Chipset Driver and then download it, follow the tutorial to update the driver. If you don’t know which manufacturer is, simply review from your computer’s document.
Step 2: Restart the computer and check whether your USB malfunctioned issue persisted or not.

By the way, you can make a backup in advance, I don't know why I lost all my data on the process, and I have to apply the Bitwar to recover them. Anyway, hope you can solve the problem soon.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...