Jump to content

Helix Native Conflict with other ASIO Applications (for example Spotify or YouTube)


Frankenkeim
 Share

Recommended Posts

Aloha,

 

I was hoping I could use Helix Native in my DAW (Reaper) at the same time as a music streaming service (Spotify) to jam along to songs. Both work individually but as soon as I open Native, Spotify stops playing since Native is causing a ASIO conflict. 

 

I know that there is a windows limitation to use ASIO in windows (one at a time) and I did download ASIO4ALL. 

 

I would assume this issue exists for every DAW and not just Reaper since it's a windows limitation, but its seems odd that I can't use what seems like a very simple configuration. I am sure I am missing something. Could any of you help please?

 

System:

Windows 10

Reaper

Helix Native

ASIO4ALL

iRIG HD audio interface

 

Link to comment
Share on other sites

HxN does not have anything ASIO related. It is just VST or AAX (Win) plugin.
Reaper can use ASIO drivers.
All of ASIO drivers I know have no limitations for ASIO clients number.
ASIO4ALL is overlay for WDM driver. Its limitation is you can not use WDM driver for device it grabs for eg. multimedia sound.
No point of ASIO4ALL usage unless you do not have (good) ASIO driver for your hardware or you want to aggregate devices.
I do not know of any ASIO implementation for Spotify software.
https://community.spotify.com/t5/Live-Ideas/Music-ASIO-Output-Support/idi-p/19519

Link to comment
Share on other sites

Is this potentially an audio interface issue? When I travel I use the iRIG HD and Helix Native. At home the LT. The LT does not have this issue and I can run Reaper, HX Edit, Spotify etc. all at the same time. 

 

Does anybody use a different audio interface and can run Spotify and Native at the same time?

Link to comment
Share on other sites

  • 3 weeks later...

hi frankenkeim,

i had a similar problem with my Audient id4 interface. what worked for me was:

 

1. search for and open "manage audio devices", select Audient id4, click properties.

 

2. a new "properties" window pops up for my id4 and I select the "Advanced" tab. 

 

3. I set "Default format" to the same sampling frequency as on the id4 settings (using my id4 app that came along with it for setting latency/sample rate/buffer size etc). In your case, i think you probably need to make sure the sampling frequency tallies with the the ASIO4ALL app settings.  I was on 44.1kHz on my Audient id4 but the "Advanced" tab  in the properties window was on 48kHz which resulted in a conflict when trying to play audio from both reaper and youtube at the same time.

 

4. i also disabled all my other audio devices and set my interface as the only default to reduce conflict otherwise the PC may try to output sound to both the usual aound card and you audio interface.

 

I'm not sure if this will work for you, hope this helps.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...