Jump to content

Helix LT midi connection locks up PC+


deoestreich
 Share

Recommended Posts

Has anyone had this issue?  Connecting a 5 pin DIN midi cable from Helix LT to PowerCab+ locks up the PC+ and renders the controls inoperable.  Amp still works, volume fixed, amp volume knob does not change level and cannot change presets.  Have to remove midi cable and cycle power to return to normal operation.  This is my second PC+ in two weeks.  First one died, was returned and this one ordered, just delivered.  Helix LT midi control worked with the PC+ that died, new PC+ configured the same.  Helix LT connected with same midi cable to Eventide H9 also works properly.  So, that pretty much leaves the new PC+ as the culprit.  Everything works as normal with no midi cable connected.  Love the sound w/Helix and PC+, just need it to work with midi and last longer than two weeks.  Since it appears to be another hardware failure I guess I'll be hauling it back to the store and have them ship me another.  Either third times the charm or 3 strikes and you're out I guess.  I am starting to question the reliability at this point.  Has anyone else had midi issues or any failures?  Or am I the lucky one to get two lemons in a row?

Link to comment
Share on other sites

I had a similar issue when I first started using MIDI with my Helix & PC+.

Their seemed to be some message conflict that would cause the PC+ to stop responding.

As you stated, it continued to work fine in the preset it was in but, would not respond to messages any more.

 

I found that I needed to set the MIDI Send/Receive in the Global Settings to OFF.

This would prevent the Helix from automatically sending a PC message any time the preset was changed.
It would then only send the PC message programmed for the preset and everything worked fine. 

It's been almost a year with no lockups or issues on the gig.

Hope this helps eh.  Happy Holidays!

 

Global Settings>MIDI/Tempo>MIDI PC Send/Receive - OFF

Link to comment
Share on other sites

Thank you bobruz!!  After reading your post.  I did some more thinking, testing and reviewed my midi settings.  I was able to send midi PC from the PC+ to the Eventide H9 with no midi in from the helix. that gave me hope and in retrospect, looking at my Helix/PC+ midi settings it "kind of" makes sense now.  I found either turning midi PC receive on the Helix off (which I don't need...not changing helix PC via midi) OR turning midi PC send off on the PC+ (in powercab edit system tab...which I also don't need) solves the problem.  And leaving midi thru on allows me to control the H9 patch changes with PC+ preset changes from the corresponding helix preset change.  It's peculiar, possibly a bug(?) and certainly not intuitive that the helix "midi receive" on (especially with nothing connected to helix midi IN) affects the helix Midi OUT especially since the behavior is locking up the PC+.  I would not expect "midi pc receive" on to have any affect on anything other than the Helix midi in connection but alas, that is not the case.   I don't recall but I'm guessing the midi PC send on the PC+ that died was turned off, I changed nothing on the helix and the behavior was different on the replacement PC+.  Since I'm using the midi thru on the PC+ for simple H9 PC messages and no other midi connected devices, leaving the PC+ midi PC send off AND Helix Midi PC receive off works fine for my configuration.

 

So, Thanks again.  It made my day.  I was getting cold feet with the PC+ after a HW failure with the first one in the first two weeks (I repaired consumer electronics and musical instruments for over 15 years in a previous life and understand the failure rate of a new device is obviously higher than one that's been reliably "burned in"...that's why we have warranties) so that was luck of the draw it seems.  With the midi problem on the new one, I immediately leaped to another HW failure especially since I was incorrectly assuming the config was identical with the one that worked (for a while).  And was dreading the whole process of boxing/exchanging/replacing/shipping/whatever again.  It's good to hear you've had no other issues.  It's restored my confidence in the helix/pc+ set up.  Thanks Much and Happy Holidays to you too!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...