Jump to content
soldierkahn

possible presence pot issue?

Recommended Posts

Long time lurker, but finally having an issue that I needed advice on. Working with a Spider Valve MKII 212 combo, I noticed after I got the amp home that the Presence knob wasnt changing anything. Unless it was maxxed out and then tapped a couple of times, there would be no tone change, so my first thought was there must be a short in the cable that carries the signal from the Presence knob to the "motherboard" (forgive me, Im a computer nerd so when i cracked the amp open, thats how i related the components). With me being able to access the cable without touching anything else, i noticed that when the "Presence" cut out giving me a super dark tone, if i lightly touched the cable anywhere, the "Presence" would turn back on.

 

So while trying to heed everyones warnings about how bad i could get hurt in there, ive been trying to troubleshoot whether or not there is anything i can do OTHER than getting the Presence pot replaced. I tried cutting the cable and splicing it (it looked like the zip tie was super tight and couldve broken the copper inside causing an intermittent short), but no difference occurred. I tried seeing if there was another cable that I could use but unfortunately the only other cable with the correct connectors connects the motherboard to the "feedback" board. For a few minutes I had considered removing the master volume pot and resoldering it in place of the Presence pot(since i can control the master volume with the FBV), but when I disconnected the Master Volume pot on the front panel(via its link cable, i didnt actualy remove the pot yet), there was no way to slightly adjust volume even with the channel volumes set low and the volume pedal setting set to max 3%. So now I know that I have to keep the master volume pot.

 

which leads me down to what i think my only option is, getting the Presence pot replaced. While it seems easy enough, as ive tons of experience soldering electronics from a young age, I was hoping there was another option available? Looking at the location of the pot, and how its on a small mini-circuit board, i could easily have enough room to suck the solder off the old pot, install the new pot and resolder, but I cannot find anywhere in the schematics as to what pot to purchase? I can live without my Presence control for now, as bypassing it doesnt hurt the tone dramatically, but I cannot get it as bright as i would prefer. If my understanding is correct, the pot is not simply a means to "cut" frequencies.... its actually a cut/boost pot. So disconnecting it affected my tone the same as if the pot was still in action but set to the 12 o'clock position, without the ability to increase or decrease brightness. Has anyone tried replacing their presence pot before? 

Share this post


Link to post
Share on other sites

First off, please keep your fingers out of the insides of these, shock hazard is too great,

it hurts when you get zapped.

 

When was the last time the tubes were changed out? What tubes are in there?

 

Share this post


Link to post
Share on other sites

not a tube issue, dont even know why that question was asked. the ONLY issue is the actual Presence knob. If I touch the presence knob, itll pop a little and then activate, after a few seconds of playing, the presence will cutout again, at which point i have to tap the Presence knob until it kicks back on. 

 

tubes were replaced last month with the reccommended tubes: 

12AX7B preamp tubes

5881WXT Sovtek (matched pair) power amp tubes.

Share this post


Link to post
Share on other sites

I asked about the tubes because of how the Presence is tied into the circuitry.

I asked about the power tube biasing for the same reason. Processor wants to

see certain things from the amp section. So biasing the power tubes correctly is crucial.

 

 

Share this post


Link to post
Share on other sites

so far, the only work ive personally done is removed the cable that connects the presence pot to the main board. It had the same affect on the sound as if i had turned the presence knob to 12 oclock, which allows me to get a fairly decent tone, without having the tone shift from dark to bright to dark to bright at random. but i would like to get my Presence capabilities back eventually

Share this post


Link to post
Share on other sites

the pot isnt soldered on? are you talking about the black sleeve that remains on the shaft after removing the knob? or are you asking me to lift the pot off of the circuit board? I want to be sure i understand :)

Share this post


Link to post
Share on other sites

Oh no, never mind. Sorry.

Forgot, the Spider Valve and Spider Amps have different pot shaft mounts.

Spider Valves are recessed.

 

Don't do anything to it.

 

Share this post


Link to post
Share on other sites

yeah I was gonna say, when i removed that circuit board i saw the pot was soldered on. i dont have a solder sucker and i dont know exactly what pot to buy to replace the dead one, so i need to know which pot to buy to replace it with please. the only identifying marks i see on the presence pot is "Alpha" on the back

Share this post


Link to post
Share on other sites

Never had to change out a volume or presence pot before. It's typically something else related,

it can fool you that way. Best to log a support ticket and have it serviced by an Line 6 authorized

service technician.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×