Jump to content
rampig59

G10 system charging issue

Recommended Posts

I have not used my Relay G10 for several months and now when the system is plugged in for charging, the base flashes RED and so does the transmitter.

After a few minutes the transmitter changes to a flashing GREEN and then goes back to flashing RED.

If I remove the transmitter from the base, the base flashes WHITE and there is NO LIGHT on the transmitter.

My software has the latest update installed.

HELP!!

  • Like 1

Share this post


Link to post
Share on other sites

I have the same problem. My receiver flashes red and transmitter nothing at all. I was able to ise it ince only and then nothing. 

Share this post


Link to post
Share on other sites

Same problem me too ....  RED the transmitter and Red or Nothing the receiver .... I tried also to update the firmware .. but nothing happen .. 

Share this post


Link to post
Share on other sites

This is just a guess, but somebody above mentioned the unit hadn't been used for several months...rechargeable batteries don't like that. Once they're dead long enough, they won't take a charge anymore. Try it with an old cell phone, tablet, ipod, etc.... or leave a vehicle sitting for an extended period without a trickle charger hooked up. At some point, there's no resurrecting them.

Share this post


Link to post
Share on other sites

Hi everyone .. 

I solved !! ..

I have downgrade the transmitter to version  1.03, I previous updated to 1.04 .. 

now it's working again ....

hope this work with you .. 

 

Share this post


Link to post
Share on other sites

thank you Tobiak

i have the G10  and used both updates and it works 

Share this post


Link to post
Share on other sites
On 5/15/2019 at 12:02 PM, tobiak said:

Hi everyone .. 

I solved !! ..

I have downgrade the transmitter to version  1.03, I previous updated to 1.04 .. 

now it's working again ....

hope this work with you .. 

 

After I have updated, my transmitter stopped charging. Tried to revert back to the old firmware but it the software cannot detect my transmitter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...