Jump to content
EooN

Helix doesn't record in Cubase LE8 and Reaper. GarageBand works fine

Recommended Posts

Hey guys!  

 

I'm a MacOS user and I've been happily recording and practicing through my Helix using GarageBand. My band is about to record a song and we decided to experiment a bit recording techniques and use my Helix to lay all guitar tracks. To better prepare I wanted to try re-amping. This can't be done in GB as I can't route track output to Helix's USB inputs. 

 

I installed Reaper to try it. It sees my Helix as an audio device, is set to record it but it doesn't. When I play on an armed track, no signal shows up on the volume meter. 

Same thing in Cubase 8 LE. 

 

I can open Repaer and get no recording singal, then Cubase and get nothing. When I open GB everything works as expected. 

 

Could you help me troubleshoot this thing please? I can provide screenshots of config screens if necessary. I think that the DAWs are pretty much the same interface-wise across OSes ;)

 

PS. If that's important I'm on a mid-2015 MBP with Mojave 10.14.3.

Share this post


Link to post
Share on other sites

Works fine in both Reaper and Cubase 10. Maybe some screenshots? Reaper would be best since I'm on a different Cubase version.

Share this post


Link to post
Share on other sites

rd2rk Thanks, but I had a lightbulb moment and managed to fixed the damned thing myself :) 

So what was wrong you may ask? I said "no"  when Repaer and Cubase asked if they could access my microphone when I run them for the very first time. Even though I didn't use a microphone as a sound input, it seems to have blocked all inputs altogether. 

 

I allowed both Reaper and Cubase to access the mic in the privacy settings et voila!

Share this post


Link to post
Share on other sites
3 hours ago, EooN said:

rd2rk Thanks, but I had a lightbulb moment and managed to fixed the damned thing myself :) 

So what was wrong you may ask? I said "no"  when Repaer and Cubase asked if they could access my microphone when I run them for the very first time. Even though I didn't use a microphone as a sound input, it seems to have blocked all inputs altogether. 

 

I allowed both Reaper and Cubase to access the mic in the privacy settings et voila!

 

I had the same problem back when Mac OS was last updated to Mojave. What a dumb thing for the Apple software people to to! Makes me wonder what kind of silly things like this will pop up in future updates.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×