Jump to content
s7nstringsofhell

Anyone use Reaper with the Helix?

Recommended Posts

Using the Helix drivers? You can try changing the buffer settings. What other programs are you running (if any) and what are the specs on the PC?

Share this post


Link to post
Share on other sites

I've been using Reaper with Helix for almost four years now... If you're getting clicks or artifacts during recording it usually means there's buffer underruns happening in your system. Those are usually caused by other hardware interrupting the audio streaming. If you download and install Latencymon, it will tell exactly where the conflicts are happening and what you should disable while recording.

 

https://www.resplendence.com/latencymon

  • Like 1

Share this post


Link to post
Share on other sites

I'm using Reaper (Win 64bit) and Helix with no issues.  I use the ASIO Helix driver in Reaper, and I didn't adjust the buffer at all.  I'm on a fairly beefy system though.  If you're using the ASIO driver already, try adjusting the slider to the right, I think, and see if that helps.

 

My only issues I have with Reaper and the Helix are pretty much entirely related to lack of talent, ability, and knowledge on how to use Reaper or how recording/mixing/mastering is supposed to work in the first place.

  • Haha 1

Share this post


Link to post
Share on other sites

I am plugged directly in via USB.

I have the helix drivers. 

I have 8700k, 370A MB SSD, 1080 Card. Its a good computer. 


Latency monitor looks way above my head. 

Share this post


Link to post
Share on other sites
5 hours ago, s7nstringsofhell said:

I am plugged directly in via USB.

I have the helix drivers. 

I have 8700k, 370A MB SSD, 1080 Card. Its a good computer. 


Latency monitor looks way above my head. 

Latency monitor is a really simple utility. You run the executable and it tells you whether you have acceptable DPC latency or not. It is that quick and simple. Give it a try is my advice. If your DPC latency is acceptable (possible) then that is not the issue.

 

If you DO have a problem with these interruptions to your audio, you will then to experiment with disabling (temporarily) various bits of non-essentail hardware/try different drivers etc to see if some peripheral or driver is messing with your s&*t. You can get help and advice on doing that here or on any tech or audio forum. We've all been there.

Share this post


Link to post
Share on other sites

If you already have increased the buffer and it doesn't help and you have a fast CPU, then check the:
Control Panel\All Control Panel Items\Power Options

 

I had it on "balanced" initially which is not good if it throttles the CPU. Try changing the processor minimum state to 100% in advanced settings. It helped me to run lower buffers when using many power hungry plugins, like Helix Native etc.

If something causes DPC latency spikes in your system, then it might not help though.

Share this post


Link to post
Share on other sites

All good suggestions so far. Something else to consider is disabling Wi Fi/Networking when you're recording. Depending on the system and what background programs may be running Windows Defender is always scanning stuff and lots of programs have background processes that cease when there is no internet connection. 

This is all useful stuff, too https://www.sweetwater.com/sweetcare/articles/pc-optimization-guide-for-windows-10/

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...