Jump to content
riclauzon

G10T not charging

Recommended Posts

I received my G10 system at Christmas (Dec 25/2018) , and for some strange reason, it just stopped charging... I use it twice a week for about avg of 2 hours.

After reading many messages on here, I can't seem to find my answer.  so here is what's happening with my G10 system . : 

- Plug in the G10T in Base... Looks, good, the G10 Transmitter flashers RED and the Receiver glows white

- After 1/2 hour, the G10T Transmitter stops flashing (emitting no lights) a,d the Receiver starts flashing Red

I tried let it charge overnight, but the G10T transmitter never gets to Green.

 

I also tried updating the G10 system using the Line6 Updater 1.16 and the updater wont allow me to use it... All I get is a black screen with "Select Device to Update".  I've tried the updater on 2 different computers using Windows 10 (Home & Enterprise).  Windows is not recognizing the G10 when plugged in to the computers... 

 

Any help would be greatly appreciated

  • Like 1

Share this post


Link to post
Share on other sites

Hey Martin, I also submitted a service request and they have contacted me.  I have to call the local distributor to try and get a replacement.

 

thanks for including me on your other post. 

 

Share this post


Link to post
Share on other sites

I also have been replaced by Sweetwater. they are the best! my unit is still in transit though but non the less, they make it a point you dont miss your gigs. =)

Share this post


Link to post
Share on other sites

replace the G10t like i had to. DO NOT update it. the update is what ruined my old g10t.

Share this post


Link to post
Share on other sites
On 10/28/2020 at 11:40 PM, thomo94 said:

replace the G10t like i had to. DO NOT update it. the update is what ruined my old g10t.

This is a 'fool me once' scenario. The life of my G10 battery is pretty degraded, but still works. (kinda, sorta...) Updating the firmware would be like entering it into hospice care.

 

When it dies, it will be replaced, but by something other than Line 6.

Share this post


Link to post
Share on other sites
The trouble cost me sick is my line6 g10s is not charging. I contacted line6 life support or support tech. This was the reply and I followed every instructions.
 
Hello leops112. Your Line 6 Support Ticket was updated with the following message:
 
Hi sorry you're running into this trouble. Could be a couple things - first, you need to verify that the transmitter was actually updated. Please run Line 6 Updater again, there should be two line items, one for the receiver, and one for G10t. The base should be v1.01, the transmitter 1.06.
 
If the transmitter is not showing -  1) try using another USB cable or port on your computer, 2) insert and remove the transmitter in base several times, only leaving it docked for a second or two each time. If the LED is flashing red, let it remain docked to charge for 5-10 minutes before re-running Line 6 Updater.
 
I hope this helps, please let me know your results.
 
Line6Josh
Now my Line6 g10s is dead after updates done. Only antenna side is blinking red while usually green blinks when charging but now no more  green lights. 
I hope, someone in line 6 support help me bury my seldom use toy. Seriously, my line6 g10s is dead. my Xvive wireless is still great and working well. I regret I bought Line6 g10s.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...