Jump to content
Sign in to follow this  
jpdennis

Helix floor model and F/W 2.71

Recommended Posts

I have been holding off since 2.70 is working well for me.  I have searched through the forum on any issues with 2.71 and the Helix floor.  Anyone have anything I should be aware of?  Would anyone share the main benefit they have received from 2.71?

 

Thanks in advance for any direction with this request

 

Dennis

Share this post


Link to post
Share on other sites

Here's what the v2.71 release notes say:

 

Bug Fixes

- On some occasions, multiple Delay block parameters would not be controlled properly when set to a footswitch - FIXED
- Other bug fixes and improvements

 

Unless you are bothered by this specific, or other unspecified, bugs there seems to be no benefit to upgrading to 2.71.

  • Like 1

Share this post


Link to post
Share on other sites
On ‎04‎/‎08‎/‎2019 at 9:04 AM, silverhead said:

Here's what the v2.71 release notes say:

 

Bug Fixes

- On some occasions, multiple Delay block parameters would not be controlled properly when set to a footswitch - FIXED
- Other bug fixes and improvements

 

Unless you are bothered by this specific, or other unspecified, bugs there seems to be no benefit to upgrading to 2.71.

 

On ‎04‎/‎08‎/‎2019 at 8:41 AM, cruisinon2 said:

At this point, you may as well wait for 2.8...

Thanks all. 

Share this post


Link to post
Share on other sites

Personally I would upgrade to 2.71. Probably not the best person to ask but I tend to rabidly embrace the bleeding edge and when feeling particularly patient usually wait no longer than the amount of time it takes for something egregious to be reported in a new firmware version before installing it (after taking precautions to back things up just in case).  My overarching strategy is that I prefer to be on the latest firmware before I upgrade on the off chance that the new firmware doesn't translate/update something properly in the presets from older(more than one release behind) firmware versions. I know Line6 goes to great lengths to make the updates backwards compatible to older firmware releases but barring something being very wrong with a newer firmware I prefer to upgrade from the most recent baseline.

Share this post


Link to post
Share on other sites
On 4/8/2019 at 8:41 AM, cruisinon2 said:

At this point, you may as well wait for 2.8...

 

WHAT? There's and update coming??? When!!??

Share this post


Link to post
Share on other sites
2 hours ago, HonestOpinion said:

Personally I would upgrade to 2.71. Probably not the best person to ask but I tend to rabidly embrace the bleeding edge and when feeling particularly patient usually wait no longer than the amount of time it takes for something egregious to be reported in a new firmware version before installing it (after taking precautions to back things up just in case).  My overarching strategy is that I prefer to be on the latest firmware before I upgrade on the off chance that the new firmware doesn't translate/update something properly in the presets from older(more than one release behind) firmware versions. I know Line6 goes to great lengths to make the updates backwards compatible to older firmware releases but barring something being very wrong with a newer firmware I prefer to upgrade from the most recent baseline.

 

HonestOpinion, have you had any issues with 2.71?

Share this post


Link to post
Share on other sites
21 minutes ago, jpdennis said:

 

HonestOpinion, have you had any issues with 2.71?

 

Not that I am aware of so far but my Helix usage is fairly straightforward. If you do something more arcane I suppose you could find something I have not. I would think the 2.71 firmware has been out long enough for most of that to have been reported although something could always slip through the cracks. A good place to check  before updating is the "Helix Bug Reports" topic but I would keep in mind a certain percentage of that will be user error.

Share this post


Link to post
Share on other sites

There is a well documented issue in here regarding 2.71 and volume issues. Tread carefully...

Share this post


Link to post
Share on other sites
7 hours ago, pb-272 said:

There is a well documented issue in here regarding 2.71 and volume issues. Tread carefully...

That's not ringing any bells with me. Can you provide a link to the issue?

Share this post


Link to post
Share on other sites
8 hours ago, pb-272 said:

There is a well documented issue in here regarding 2.71 and volume issues. Tread carefully...

 

That's news to me... what issue? 

Share this post


Link to post
Share on other sites
18 hours ago, HonestOpinion said:

 

Not that I am aware of so far but my Helix usage is fairly straightforward. If you do something more arcane I suppose you could find something I have not. I would think the 2.71 firmware has been out long enough for most of that to have been reported although something could always slip through the cracks. A good place to check  before updating is the "Helix Bug Reports" topic but I would keep in mind a certain percentage of that will be user error.

 

3 hours ago, cruisinon2 said:

 

That's news to me... what issue? 

HonestOpinion commented about 11 hours ago concerning one item identifying a volume pedal issue.  HonestOpinion wasn't able to replicate the issue and asked the OP to check global settings.  Most everything else is for the Stomp except something concerning the midi send commands; that is only on one post as I can tell.

Share this post


Link to post
Share on other sites

Thanks. So it's well documented non-reproducible issue that may boil down to an incorrect setting?

 

@pb-272... is this what you are referring to?

Share this post


Link to post
Share on other sites
14 hours ago, pb-272 said:

There is a well documented issue in here regarding 2.71 and volume issues. Tread carefully...

 

6 hours ago, silverhead said:

That's not ringing any bells with me. Can you provide a link to the issue?

 

I think he may be referring to the topic below. It appears pb-272 was one of the users impacted by this. There may potentially be a bug or issue impacting only a handful of users. Could be something in only some select users preset(s), hardware, or upgrade process that causes a problem. I have not seen this widely reported but I could be wrong. As always it is just step number one to create backups before a firmware upgrade so you can roll back if necessary.

 

 

Share this post


Link to post
Share on other sites

Thanks for the link. I had missed that discussion.

Share this post


Link to post
Share on other sites

it has affected several but not all Helix owners.  I did upgrade to 2.71 and noticed the volume was very slightly lower on all my custom built presets.  Not a big deal right now as I am still going to be working with the sound engineer before this weekend's job.  However, I am not getting the issue described in the link HonestOpinion shared

Share this post


Link to post
Share on other sites
12 hours ago, jpdennis said:

it has affected several but not all Helix owners.  

 

Well, I updated very soon after the release and (fingers crossed) not had any problems so far, although the version is listed in my
Global Settings window as Firmware Version 2.71.0 -9d66a1f.

 

Ferktifino what that stuff after the two dot, seven one, dot zero refers to, must mean something to the Line 6 Crew - stray bit of code?

Share this post


Link to post
Share on other sites
5 hours ago, datacommando said:

 

Well, I updated very soon after the release and (fingers crossed) not had any problems so far, although the version is listed in my
Global Settings window as Firmware Version 2.71.0 -9d66a1f.

 

Ferktifino what that stuff after the two dot, seven one, dot zero refers to, must mean something to the Line 6 Crew - stray bit of code?

 

Well, I created a new patch and discovered the issue with the volume was my tired ears.  I was victim of ear fatigue.  The patches are fine and no issues so far.  I played for about an hour today as well as modified some patches for this weekend; nasty cold has got me home so I felt restless.  No issue with volume, volume pedal, patch import export, etc.

 

One thing of interest is that I have my Helix onto the APC side of my APC UPS and we had a slight power outage for about a second.  My laptop was fully changed so that was good as well.  I now have a story to tell me fellow performers who laughed at my neurosis.  LOL

 

Dennis

  • Haha 1

Share this post


Link to post
Share on other sites

Sorry, just saw this, been offline for a while. I upgraded 2 helix floor units and one rack (all purchased in Australia around the same time) and had been upgrading each time there was a new version with the usual frustrations but no major problems until 2.71. All three units froze during the last step which was a patch rebuild. I had to turn the unit off and reboot - no sound. I simply repeated the upgrade, experienced the same exact pattern, then had sound. It's a weird one, makes no sense, however the units have been fine ever since. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×