Jump to content

Shuriken firmware issues - Solved.

Recommended Posts

I have had my Shuriken since they were initially released (i pre-orered mine). 

I have NEVER connected it to a computer for updating. 

Using my iMac and the Line 6 USB dongle, I'm attempting to update the firmware on the Shuriken as well as a JTV-59. 

The green light is on for the USB side of the dongle, red light blinks on the variax cable side. I've tried different cables. I have 2 (1 brand new) Line 6 Neutrix Variax cable and I've tried different networking cables (which work with the Helix Rack controller fine). I've made sure both batteries have a fresh charge and 4 dots light up green on the battery box indicator. 


I'm running latest versions of all software (line6 Monkey and Workbench HD matter here). 



Please advise. This is frustrating. Dump all this money into gear... 





It's almost 2020 people. Dongles suck. 


Yes, I've searched for an answer to this in your database. 




I solved the problem. 


When using the DONGLE, the 1/4" cable plugged into the variax guitar caused me problems. I use high-end cables and tried 3 different cables before unwrapping a new 1/4" cable I have and trying it. 

It failed on me 2x (with guitar hanging on a stand untouched during update) - but the 3rd time was a charm on the Shuriken. The JTV-59 updated 1st time, no problems. 


With Helix being 3 years old now, I don't understand why this isn't executable using the Helix while connected to a computer. 


For something we do once in a blue moon... I guess it's not a priority. 


Thanks for reading. 



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now