Jump to content

New Spider V 240 combo broken?


juzzy1212
 Share

Recommended Posts

Hi all, I got a new Spider V 240 combo today and I was really excited to try it out but it sounds awful, I think it may be broken, I was just wondering if anyone else has experienced anything similar?

 

Basically, the amp sounds great through headphones or direct into my Mac but the actual amp speakers sound really muffled / muddy, sounds like there is a pillow or something in front of the speakers. I have tried updating the amp, adjusting the EQ, assorts of parameters but no joy, still sounds bad. I have a horrible feeling I have a faulty amp but I thought I would ask here in case anyone has any suggestions.

 

Thanks 

Link to comment
Share on other sites

Idid not have this problem when I got mine a year ago .  Check to see if All the selections are as they should be in the main menu....Ii.e  ...Press the home button down for a few seconds until the menu pops up.  See if the selections are correct for the amp as you want it.  You probably have done this already.   I do not know outside of this as to what may be wrong.  If I were you I would return and exchange it.  There is great joy in getting another one that works! It is a GREAT amp.  

Link to comment
Share on other sites

Ok, I am sending it back, after having a proper look it seems that the tweeters are not working, I don't know if its the speakers or the amp causing the problem but I will be getting a refund, its a shame, I really wanted to try out the amp but it has put me off getting another one.

Link to comment
Share on other sites

  • 2 weeks later...

your description of the sound pretty much describes my reaction when I first heard one ...... sounded tiny and with a pillow in front of the speakers .. sadly most of the presets are ultra lame, the amp sounds fantastic when you make your own . but the tweeters ARE directional , these 2 way hifi speaker systems are a lot clearer when the amp is tilted back if on the floor 

Link to comment
Share on other sites

  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...