Jump to content
Sign in to follow this  
Sacrifice82

Problem with connection windows 10

Recommended Posts

Hey all! I have a problem with my Pod HD500X. Im trying to connect my pod with a computer using a usb cable. But my system doesnt recognize the device.It shows that something is connected to computer by usb cable but device is not recognized. Same problem with Pod HD500X Edit. It looks like device is not connected but its connected. Cable is good. Could it be something with an usb port in Pod? 

Share this post


Link to post
Share on other sites

Did you try a different USB port on the computer ?  

Share this post


Link to post
Share on other sites
3 hours ago, Sacrifice82 said:

It shows that something is connected to computer by usb cable but device is not recognized. 

 

Since Windows 10 reports >>something<< connected, the USB cable is probably OK.

Not recognizing the device typically means the driver is missing;  download it from Windows HD500X driver Version 4.2.7.6 Released 8/21/15

Share this post


Link to post
Share on other sites

I did download the driver. My friend told me that it can be chip broken. I had an accident while cable was connected to computer. I dont how to write correctly but when i touched m computer short circuit happened. Had to buy chipset, procesor and ram memory. I think the same happened to my Pod. I did check different usb ports. Even checked on 2 more computers. 

Share this post


Link to post
Share on other sites

Whoa, I think you need to explain in more detail what happened.  Sounds like everything got zapped.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×