Jump to content
Sign in to follow this  

Mic Trim Does Not Do Anything

Recommended Posts


I bought my JM 4 used in the US, but only when I really started to use it (which was when I was back in Germany), I noticed that the Mic Trim poti doesn't work at all. I do get a signal though, and the Signal Level Settings in the display work, but I cannot give any extra gain level with a low output microphone (like my Beyer Ribbon mic)!!! Any ideas from a distance? If the poti was really broken, the mic input would probably not work at all, no?

I'm quite good in fixing obvious things with a soldering iron, but I'm not enough of an electronic freak to measure and analyze what's wrong with a cirquit.




Share this post

Link to post
Share on other sites

I could only guess the one obvious thing to check, I only got one of these 3 days ago, but, have you got the top left button toggled to the mic when you're testing?

Tried any other mics at all? Tried your guitar in the same input, just to test that pot etc?

Hope that might help.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this