Jump to content
Sign in to follow this  
mbtainton

VP Jr not working properly with Helix LT

Recommended Posts

I have a passive VP Jr plugged into the Exp 2 jack using a TS cable (standard pedal patch cable) but it goes from 0 to 100 at about half way through the pedal sweep and then 0 as soon as the sweep hits about 75%.  I’ve tried using a TRS cable just in case that helped (it didn’t help). I’ve tried reversing the polarity in the Helix settings (just goes 100 - 0 - 100 then).

 

I got the VP Jr because people have used it with the Helix just fine and I like it more than the Mission L6-1 pedal. 

 

Why does the VP Jr behave like this?

Share this post


Link to post
Share on other sites
11 hours ago, mbtainton said:

I have a passive VP Jr plugged into the Exp 2 jack using a TS cable (standard pedal patch cable)

 

Did you try the cable in both the input and the output of the VP JR? The in/out will behave differently so try them both. 

 

11 hours ago, mbtainton said:

 I’ve tried using a TRS cable just in case that helped (it didn’t help).

 

The Helix would prefer a standard cable. If you do try a TRS it must be an "insert cable" (two mono ends at the VP Jr side), not just a cable with two TRS ends on it. When using an "insert cable" the same applies to the "in/out" on the VP Jr that I mentioned above... you would need to try both orientations. 

 

11 hours ago, mbtainton said:

I got the VP Jr because people have used it with the Helix just fine and I like it more than the Mission L6-1 pedal. 

 

Why does the VP Jr behave like this?

 

There are two VP Jr's. The passive VP JR is a 250k pot... The active VP JR uses a 25k pot.

L6 loves to see a 10K pot so I suspect you might be better results with the active pedal.

 

That said... I have seen people state that they use the passive VP Jr and it works fine.

 

Share this post


Link to post
Share on other sites
20 minutes ago, codamedia said:

 

Did you try the cable in both the input and the output of the VP JR? The in/out will behave differently so try them both. 

 

 

The Helix would prefer a standard cable. If you do try a TRS it must be an "insert cable" (two mono ends at the VP Jr side), not just a cable with two TRS ends on it. When using an "insert cable" the same applies to the "in/out" on the VP Jr that I mentioned above... you would need to try both orientations. 

 

 

There are two VP Jr's. The passive VP JR is a 250k pot... The active VP JR uses a 25k pot.

L6 loves to see a 10K pot so I suspect you might be better results with the active pedal.

 

That said... I have seen people state that they use the passive VP Jr and it works fine.

 

 

Yeah, I tried both input and output jacks on the VP. Got nothing from the input jack and the stated problem from the output jack. 

 

I did wonder if the people using VP Jrs successfully had the 25k active pedals. I’m half inclined to just get a Dunlop mini volume on the used market and try that instead. 

Share this post


Link to post
Share on other sites
15 minutes ago, mbtainton said:

I’m half inclined to just get a Dunlop mini volume on the used market and try that instead. 

 

Do you know if that works with the Helix, or would you still be in trial and error mode?

There are many ways that an expression pedal can be wired.... everything is NOT compatible with everything. 

 

Out of curiosity... what version of firmware is your Helix running? Supposedly, V2.71 made large improvements to expression/VP compatibility. 

 

Share this post


Link to post
Share on other sites
8 hours ago, codamedia said:

 

Do you know if that works with the Helix, or would you still be in trial and error mode?

There are many ways that an expression pedal can be wired.... everything is NOT compatible with everything. 

 

Out of curiosity... what version of firmware is your Helix running? Supposedly, V2.71 made large improvements to expression/VP compatibility. 

 

 

I’m on the latest firmware. 

 

Yeah, I’d still be in trial and error mode. People on here have used the Dunlop VP with no issue. But then, people have had no issue with the Ernie Ball too so who knows?

Share this post


Link to post
Share on other sites

From my direct experience, a VP Jr. with a mono patch cable in the output jack, leading to the exp. input of the Helix should work. I wonder if you need to roll the potentiometer backwards a bit in the pedal. It may have slipped against the string at some point.  Also, does your pedal have a taper switch inside? You might try tweaking it, if so. Good luck!

  • Like 1

Share this post


Link to post
Share on other sites

Yeah, I reckon it’s the pot that’s broken or needs resetting. 

Share this post


Link to post
Share on other sites

Opted for the $0 fix. Found a bit of rubber with an adhesive backing and stuck it at the front of the VP so now it travels from 0 - 100 in the Helix and can’t travel past the point where it returns to 0 when fully pressed.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×