Jump to content
misla1

Helix as Audio Interface with Ableton Volume Issues

Recommended Posts

Hello All,

I am trying to figure out how to control the volume of my backing tracks when I am recording guitar through the Helix.  Here is my set up:

 

Macbook Pro > USB to Helix 3/4 > XLR outs to Studio Monitors

 

My Helix has two paths--Path A is my guitar patch to Multi Out (which goes to either my Headrush via 1/4 inch or to studio monitors)  

                                            Path B is 3/4 USB input to XLR out to Monitors

 

***The Problem #1--I am recording without headphones and the Helix (guitar) is significantly louder and I can't seem to control the volume of the backing track probably because they are both on the same volume from the Helix.  Is there a way to do this or should I just get another Audio Interface just for my mac?

 

***Problem #2 The latency is so bad if I use headphones it's unusable .  At 512 the latency is so far behind it's hard to play in time and you cannot adjust the Helix's sample rate below 48000. (At lower sample rates I get the popping and scratching sound so that doesn't work either)  Any suggestions on using the Helix with headphones and not getting such bad latency?

 

Thanks for your help! 

Share this post


Link to post
Share on other sites

The usual way to do this is to set the output on your guitar path to 1/2 with the BIG KNOB set to control the 1/4" outs. That controls the guitar>Headrush level.

In GLOBALS/INS-OUTS set "USB 1/2 Destination" to XLR.

 

>In your DAW, turn OFF the guitar track monitor button.<

 

With your DAW Master set to Output 1/2, now you're hearing your tracks thru your monitors, but your guitar is LIVE thru the Headrush - ZERO LATENCY!

Control the track mix and levels with the track sliders and Master slider.

 

If you're using 3/4 to further process the guitar signal through effects in your DAW, you're SOL. THAT'S what's causing the latency.

 

You should be able to set your buffers down to at LEAST 128 without crackling/popping, unless you're using an ancient Mac with less than a Core 2 Duo and 8mb memory. It would have to be REALLY old!

Share this post


Link to post
Share on other sites
18 hours ago, rd2rk said:

The usual way to do this is to set the output on your guitar path to 1/2 with the BIG KNOB set to control the 1/4" outs. That controls the guitar>Headrush level.

In GLOBALS/INS-OUTS set "USB 1/2 Destination" to XLR.

 

>In your DAW, turn OFF the guitar track monitor button.<

 

With your DAW Master set to Output 1/2, now you're hearing your tracks thru your monitors, but your guitar is LIVE thru the Headrush - ZERO LATENCY!

Control the track mix and levels with the track sliders and Master slider.

 

If you're using 3/4 to further process the guitar signal through effects in your DAW, you're SOL. THAT'S what's causing the latency.

 

You should be able to set your buffers down to at LEAST 128 without crackling/popping, unless you're using an ancient Mac with less than a Core 2 Duo and 8mb memory. It would have to be REALLY old!

This works great but the now the issue is that my DAW does not pick up the signal of the guitar.  So this is basically what I use for live performances but still have the issue with getting the sound into the DAW for recording.  It's all set to master output 1/2.

Share this post


Link to post
Share on other sites

It would help if you identified your DAW.

In your DAW's "Options" or "Preferences", is the Helix and all it's inputs/outputs selected as the ASIO device? This might be called something different on a MAC.

On the guitar track, is the input set to 1/2 (Helix processed) or 7/8 (Helix clean)? Either will work, and I usually use both, on separate tracks, in case I want to use a plug-in to get a different tone on the clean track.

Usually, the RECORD button on the guitar track needs to be activated, whether the track is actually recording or not. Just remember to keep the Track Monitor button OFF or you'll get an echo effect that reflects the latency difference between the LIVE signal and the signal from the DAW.

Share this post


Link to post
Share on other sites
8 minutes ago, rd2rk said:

It would help if you identified your DAW.

In your DAW's "Options" or "Preferences", is the Helix and all it's inputs/outputs selected as the ASIO device? This might be called something different on a MAC.

On the guitar track, is the input set to 1/2 (Helix processed) or 7/8 (Helix clean)? Either will work, and I usually use both, on separate tracks, in case I want to use a plug-in to get a different tone on the clean track.

Usually, the RECORD button on the guitar track needs to be activated, whether the track is actually recording or not. Just remember to keep the Track Monitor button OFF or you'll get an echo effect that reflects the latency difference between the LIVE signal and the signal from the DAW.

I am using Ableton 10.1 Suite.  Both the input and output are set to Helix and I have recorded this way before but with terrible latency which is why I wanted to record without headphones.  The audio track to the right of the preferences is the Helix track and the record button is armed but doesn't detect a signal.  The Track monitor is off.  I am thinking I might need a separate audio interface between my mac and monitors and connect the helix outside of that chain.

 

Screen Shot 2019-07-02 at 1.20.28 PM.png

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/2/2019 at 11:23 AM, misla1 said:

I might need a separate audio interface between my mac and monitors and connect the helix outside of that chain.

 

If you like to waste money, by all means buy another interface.

I also use Live 10. Works FINE with Helix.

 

Here's my Preferences and the Track setup, Inputs and Outputs. I'm using the Helix Stomp in this example, so the CLEAN Input is 5/6 not 7/8 as on the full Helix.

 

EDIT: Images removed to recover attachment allotment

 

 

 

Edited by rd2rk
Image removed to recover attachment allotment

Share this post


Link to post
Share on other sites

Here's the Preferences and track setup for recording Processed and Clean tracks simultaneously. Remember, on the full Helix the Clean track is set to 7/8

 

 

 

Share this post


Link to post
Share on other sites
7 minutes ago, rd2rk said:

Here's the Preferences and track setup for recording Processed and Clean tracks simultaneously. Remember, on the full Helix the Clean track is set to 7/8

 

 

LIVE10 Track Setup and Preferences.png

 

 

I think this is working now and since I added the output it's all coming out of the monitor but levels seem ok--this is pretty confusing when mixing the two but I am going sit on this for a few days of recording and see what's going on.

 

Do you ever use headphones for monitoring?  When I do it's bad at 128 it crackles but even at 256 there can be some issues---as sometimes I want to record before the sun comes up.

 

Share this post


Link to post
Share on other sites

It seems to me that you're making things unnecessarily complicated. I'm not sure I understand why you want to have a separate path in the Helix for your backing track. As long as the Helix is your system's audio interface, all system audio will be played back to it over USB 1/2. If you want to control the volume of that audio stream from the Helix, you can go to Global Settings>Ins/Outs>USB In 1/2 Trim. Better than that, though, would be to simply lower the fader for the audio track in Ableton. Then as far as the guitar, you shouldn't be direct monitoring that through Ableton - you should be hearing it in real-time through the Helix's outputs. So both the track and the guitar will be sent to the same physical outputs.

Share this post


Link to post
Share on other sites
5 minutes ago, misla1 said:

 

 

I think this is working now and since I added the output it's all coming out of the monitor but levels seem ok--this is pretty confusing when mixing the two but I am going sit on this for a few days of recording and see what's going on.

 

Do you ever use headphones for monitoring?  When I do it's bad at 128 it crackles but even at 256 there can be some issues---as sometimes I want to record before the sun comes up.

 

 

If the entire signal (backing/previously recorded tracks AND guitar) is coming out the monitors DURING recording, you've still got the monitor switch on. Configured as I've described, the guitar signal should be separate from the rest, which allows you to hear it better (and without latency or crackling) during recording. Playback will be the mix, all in the monitors.

 

CracKling at low buffer settings indicates that your computer is low on resources. Since I don't use a MAC, I can't tell you how to optimize it for audio. Certainly, at the least, all non-essential programs should be closed and wireless turned off. Those are the basics, you should Google for more info on optimizing a MAC for Audio production.

 

Any crackling should be audible regardless of whether you're listening on headphones or speakers. If it's only on your headphones, try better (newer?) headphones.

 

What are the HW specs on your MAC?

Share this post


Link to post
Share on other sites

What phil_m just said is essentially what I've been telling you, the second path in your example preset is unnecessary.

Share this post


Link to post
Share on other sites
On 7/2/2019 at 2:14 PM, phil_m said:

It seems to me that you're making things unnecessarily complicated. I'm not sure I understand why you want to have a separate path in the Helix for your backing track. As long as the Helix is your system's audio interface, all system audio will be played back to it over USB 1/2. If you want to control the volume of that audio stream from the Helix, you can go to Global Settings>Ins/Outs>USB In 1/2 Trim. Better than that, though, would be to simply lower the fader for the audio track in Ableton. Then as far as the guitar, you shouldn't be direct monitoring that through Ableton - you should be hearing it in real-time through the Helix's outputs. So both the track and the guitar will be sent to the same physical outputs.

The problem with this is that the guitar is monumentally louder than the backing tracks on Abelton.  So even if I turn up the track volume all the way to red on my DAW the guitar is still too loud.  When I adjust the trim in global settings it also turns down the track volume and keep the guitar volume louder as if there are set.  And of course none of this fixing the awful latency problem I have when using headphones.  I am at a loss. 

 

Share this post


Link to post
Share on other sites
On 7/2/2019 at 11:58 AM, misla1 said:

Do you ever use headphones for monitoring?  When I do it's bad at 128 it crackles but even at 256 there can be some issues---as sometimes I want to record before the sun comes up.

 

Headphones have nothing to do with crackling, unless your headphones are really crap or defective.

 

I'll point out AGAIN - you should be monitoring your guitar DIRECT through the Helix while recording, NOT through the DAW!

Monitoring DIRECT through the Helix results in ZERO latency and ZERO crackling!

 

That you're still getting both indicates that YOU"RE DOING IT WRONG!

 

Duplicate the screenshots I sent you.

 

Make sure that, In Helix Globals, USB 1/2 Destination is set to whichever monitors you want to hear your PLAYBACK through (XLR in your case) - while recording, you should only be hearing your guitar through your amp (1/4" L/Mono out). On your computer, the soundcard should be set to the computers's soundcard. In your DAW it should be set to Helix.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×