Jump to content
jhahn53

G10S will work from USB input but not 9V input.

Recommended Posts

What goes wrong inside a G10S when it will work from a USB source but not the factory 9V supply...   I checked the supply with a volt meter and it seems ok.  Only had the unit a few months...

Share this post


Link to post
Share on other sites
On 7/11/2019 at 2:37 PM, jhahn53 said:

What goes wrong inside a G10S when it will work from a USB source but not the factory 9V supply...   I checked the supply with a volt meter and it seems ok.  Only had the unit a few months...

 

Since you've already confirmed that the power supply itself works, and the base unit functions with USB power, then pretty much all you're left with is the power supply jack on the base unit... there will be a couple of solder joints behind there somewhere, connecting the jack to the rest of the guts... loose solder joints are certainly not unheard of. Before taking it apart though, I'd try another power supply just for giggles... it's the easiest and least invasive way to confirm the jack itself as the problem.

Share this post


Link to post
Share on other sites

I have this exact issue.  I guess I need to send it in for warranty repair.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...