Jump to content
PierM

[SOLVED] Installed 2.8, Helix Rack bricked. Can't roll back. Boot Mode does fail.

Recommended Posts

1 minute ago, clamdiper said:

I am 100% busted. Read through all this and nothing helps. Stuck in the Boot failure screen and can't even get Global Reset to work. Says it's initiating then it goes back into the same error.


I take it I now have a $1500 boat anchor?

 

If you run the Helix (it should put itself in update mode, since it's failing to start the firmware), and then the Line 6 updater, what does the updater says? Just start from there, and see how the updater see your helix.

 

It should show you the firmware version (broken) on the unit. If does says 2.7, try reinstalling the 2.7.

 

Share this post


Link to post
Share on other sites

I had a few issues updating, but after getting stuck, I reinstalled the HX Edit 2.80 software and restarted and everything was good. The issue I'm having right now is trying to restore a setlist. For one of them, it's somehow corrupted the setlist and when I try to load it, it throws an error in HX Edit.

 

error1.png

Share this post


Link to post
Share on other sites
59 minutes ago, clamdiper said:

I am 100% busted. Read through all this and nothing helps. Stuck in the Boot failure screen and can't even get Global Reset to work. Says it's initiating then it goes back into the same error.


I take it I now have a $1500 boat anchor?

 

If you haven't tried the remedies above yet with different USB ports or a different computer and cables I would try that first. If not call or open up a ticket with Line6.  I am about 99.9% sure you don't have a boat anchor and they will be able to get you back on track.

Share this post


Link to post
Share on other sites
19 minutes ago, PierM said:

 

Based on what happened to me today, I would suggest this;

  1. Start the Rack while pressing the encoders 1 and 6, this should put the rack into update mode (KEEP THE HELIX CONTROL OFF).
  2. Start the Line 6 updater 1.17 (the latest) and see how your unit is now enumerated (firmware version number)
  3. If does show Helix Rack 2.8, then you can try reinstalling the firmware and see what happens
  4. If does show Helix Rack 2.x, then you should reinstall THAT SPECIFIC firmware; for example, if it's showing Helix Rack 2.7, try reinstalling the firmware 2.7.
  5. If you manage to roll back to a stable firmware just try again the procedure but this time, when the helix reboot itself, DO NOT shut it off, just do NOTHING to it and wait for the updater to finish and/or fail.
  6. If the updater does fail, just keep the Helix as it is (DO NOT TURN IT OFF) and restart the updater.
  7. At this point go back to point 2 again.

 

Thanks for the help

When I start the unit pressing 1 and 6, the Racks screen says Entered Update Mode! but Line 6 updater 1.17 just stays blank and can't see the device to update 

What next I'm thinking factory reset ?

Share this post


Link to post
Share on other sites
1 minute ago, MarkeG said:

 

Thanks for the help

When I start the unit pressing 1 and 6, the Racks screen says Entered Update Mode! but Line 6 updater 1.17 just stays blank and can't see the device to update 

 

 

Change USB port on the PC and try again.

Try all the USB ports you have before to give up.

Share this post


Link to post
Share on other sites
29 minutes ago, johnrjackson said:

I had a few issues updating, but after getting stuck, I reinstalled the HX Edit 2.80 software and restarted and everything was good. The issue I'm having right now is trying to restore a setlist. For one of them, it's somehow corrupted the setlist and when I try to load it, it throws an error in HX Edit.

 

error1.png

 

If all else fails if you did a "Create Backup" before your upgrade you can try doing a "Restore Backup" using the method I posted in the link below. I would do a new "Create Backup" as well as backing up your individual setlists before embarking on this method.  When you restore though you will be using the backup you made previous to the upgrade that included your setlist that is now not loading.

 

 

Share this post


Link to post
Share on other sites
5 minutes ago, PierM said:

 

Change USB port on the PC and try again.

Try all the USB ports you have before to give up.

 

Changing ports did the trick its letting me update again :)

That worked picky picky Windows USB ports  will get you every time 

 

Thanks 

  • Upvote 1

Share this post


Link to post
Share on other sites
14 minutes ago, HonestOpinion said:

 

If all else fails if you did a "Create Backup" before your upgrade you can try doing a "Restore Backup" using the method I posted in the link below. I would do a "Create Backup" as well as backing up your individual setlists before embarking on this method.

 

 

 

Thanks, the restore from backup worked!

 

Share this post


Link to post
Share on other sites
5 hours ago, PierM said:

 

The solution for me was TO NOT reboot the helix, but only restart the updater.


If when you restart the updater, it will see your helix as 2.8, means it has been enumerated as 2.8, and you can try installing 2.8 again. It should then start quickly from there, and complete the process in a matter of minutes.

 

Good luck!

 

 

Thank you got stuck at 50% and used your method all good - your the best

  • Upvote 1

Share this post


Link to post
Share on other sites


I don't remember seeing  Helix always rebuilding  its presets each time you turn it on is this something new or just early signs of dementia ?

Also after updating my Tap/Tuner button keeps blinking can some refresh me on how to turn that off ?

Share this post


Link to post
Share on other sites
2 hours ago, MarkeG said:


I don't remember seeing  Helix always rebuilding  its presets each time you turn it on is this something new or just early signs of dementia ?

Also after updating my Tap/Tuner button keeps blinking can some refresh me on how to turn that off ?

 

1ST thing I had to do - go to global settings - displays - 2 options its the second one turn it off  :)

 

 All my payware presets are still there - good job line6 - have to try it out now - if you get stuck at 50% shut down updater and start it again first - easiest thing to try first - thanks again to OP

  • Thanks 1

Share this post


Link to post
Share on other sites
4 hours ago, Dire said:

Same here Helix LT stuck at 50% forever. Tried to restart, now the helix is not recognized anymore by the updater and stuck in boot mode.

I have the same as above. Restarted but Helix is no longer recognized.  Helix continues to show "Boot Failure, entered Update Model" and editor does not see the helix. 

 

Tried various iterations of turning stuff on and off: no effect. 

Tried moving off of my powered USB hub (only mouse and helix on computer): No effect on Helix or update, successful in raising my concern I really screwed this up.

Updater was updated prior to starting the update (running 1.17)

Backup completed before update.

Windows 10

 

 

Share this post


Link to post
Share on other sites

Tried EVERYTHING on here and it's still lollipoped.

lollipop you Line 6

Share this post


Link to post
Share on other sites
10 minutes ago, Slimo said:

Tried EVERYTHING on here and it's still lollipoped.

lollipop you Line 6

 

Hi Slimo,

 

You say that you tried “EVERYTHING” on here, but did you follow the installation instructions posted here:

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, datacommando said:

Yes

Hi Slimo,

 

You say that you tried “EVERYTHING” on here, but did you follow the installation instructions posted here:

 

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites
1 hour ago, Slimo said:

Tried EVERYTHING on here and it's still lollipoped.

lollipop you Line 6

 

LOL Good one - good luck getting it working you will figure it out

Share this post


Link to post
Share on other sites

Boot failure entered update mode. Only boot option that does anything is 6+12 (Entered Update Mode!), everything else goes to boot failure screen with :-3 in top left.

Line 6 updater doesnt find any devices connected so cant update. Tried 2 different cables in EVERY USB slot. Restarted PC and everything else I can think of.

Please help, this is lollipop.

Share this post


Link to post
Share on other sites
1 minute ago, Slimo said:

Boot failure entered update mode. Only boot option that does anything is 6+12 (Entered Update Mode!), everything else goes to boot failure screen with :-3 in top left.

Line 6 updater doesnt find any devices connected so cant update. Tried 2 different cables in EVERY USB slot. Restarted PC and everything else I can think of.

Please help, this is lollipop.

 

You are understandably upset by this situation and come here seeking help, but the attitude needs adjusting.

 

Take a deep breath and think what you have told us?

 

Not very much!

 

What Helix, Floor, Rack, LT?

 

What computer system and OS?

 

Supply the most info you can and you may get some valuable assistance.

 

It won’t be from me tho’, I’m going for a beer!

 

Goodnight.

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, phil_m said:

 

I would try updating with a different USB port and/or cable.

Windows 10 user here.

 

The update went fine but after the successful update the laptop stopped seeing any device at all plugged in. There was a flag in the USB controller under device manager.  Switched ports on secondary USB controller and device was detected.

 

Uninstalled the flagged controller, had device manager scan for hardware changes, it refreshed the driver, and it restored and the controller worked detected Helix.

 

Never had a driver issue with the controller before.  It seems like the process affected the controller driver.  Using a 6 year old Samsung. "Core i7 CPU" 

 

So update issues may not be exclusive to win7 but to older hardware as well.

Share this post


Link to post
Share on other sites

exact same issue as above thread

I submitted a ticket as well I know Line6 will fix this but will it cover out of warranty units? I am very disappointed and nervous like everyone else here

Here is how this all happened

  • Helix was on version 2.71
  • Window 10 laptop with both USB 2.0 & 3.0, Helix was always connected through USB 2.0 (I use this regularly as an audio interface and jam with some online backing tracks) so no problem with either port or cable in last one+ year
  • While updating Helix it got stuck with  "Boot Failure. Entered Update Mode!" message and :-3 on top left corner of screen
  • Nothing worked, till I tried pressing switches 6 + 12 and restarting Helix, with that now I just have "Entered Update Mode!" message and I dont know what to do next
  • At this point, based on messages on other forums, connecting USB cable and running "Line 6 Updater" should fix the problem, but problem is "Line 6 Updater" doesnt even see Helix, actually I went through my DAW and sound settings and Helix is not recognized anywhere, the only thing that tells me "something" might be working, is when I plug USB in/out or turn Helix off/on I hear that same windows system sound when you plug in a USB device
  • I have since tried different cables, both USB 2.0/3.0 ports, I even rolled back USB drivers, installed new again, rolled back Line 6 Updater to 1.5 but Helix is not recognized, hence cant get to next steps

I am in IT, and our rule of thumb is, if a patch is released, wait for next one before applying that patch or at least wait a month before updating, I preach that at work and didnt practice same when at home. :(  

Edited by rijiboy
typo

Share this post


Link to post
Share on other sites

I had the same issue with Windows 10 on my floor unit. Nothing worked. I have an older Macbook, so i installed the updater on it, and it recognized the floor unit and the update seemed to proceed. It appears to be rebuilding presets now.

 

If you are having problems with using a PC with Windows, find someone with a Macbook and see if they'll let you borrow it. Good news is that your HElix is not bricked... just need to find a computer that will finish (or re-do) the update.

Share this post


Link to post
Share on other sites
23 minutes ago, rijiboy said:

exact same issue as above thread

I submitted a ticket as well I know Line6 will fix this but will it cover out of warranty units? I am very disappointed and nervous like everyone else here

Here is how this all happened

  • Helix was on version 2.71
  • Window 10 laptop with both USB 2.0 & 3.0, Helix was always connected through USB 2.0 (I use this regularly as an audio interface and jam with some online backing tracks) so no problem with either port or cable in last one+ year
  • While updating Helix it got stuck with  "Boot Failure. Entered Update Mode!" message and :-3 on top left corner of screen
  • Nothing worked, till I tried pressing switches 6 + 12 and restarting Helix, with that now I just have "Entered Update Mode!" message and I dont know what to do next
  • At this point, based on messages on other forums, connecting USB cable and running "Line 6 Updater" should fix the problem, but problem is "Line 6 Updater" doesnt even see Helix, actually I went through my DAW and sound settings and Helix is not recognized anywhere, the only thing that tells me "something" might be working, is when I plug USB in/out or turn Helix off/on I hear that same windows system sound when you plug in a USB device
  • I have since tried different cables, both USB 2.0/3.0 ports, I even rolled back USB drivers, installed new again, rolled back Line 6 Updater to 1.5 but Helix is not recognized, hence cant get to next steps

I am in IT, and our rule of thumb is, if a patch is released, wait for next one before applying that patch or at least wait a month before updating, I preach that at work and didnt practice same when at home. :(  

 

Don't sweat it, Line6 will help you in or out of warranty. Don't think this this is going to be a hardware issue.

 

Looks like you have tried several of the correct recovery steps. I don't see here specifically that you downloaded and installed the "HX Edit (version 2.80)" package. Perhaps you have but since that contains the driver, updater, and editor it is a better way to make sure you have them all synched up. As you indicated best to uninstall the Line6 software first at this point before reinstalling HX Edit 2.8. Once you start rolling back with separate versions of the updater and editor, etc. things have a good chance of going wonky. I would reboot the PC for good measure too. As always never have HX Edit and the Updater running at the same time as they interfere with each other's ability to recognize the Helix.

  • Upvote 1

Share this post


Link to post
Share on other sites
6 minutes ago, HonestOpinion said:

 

Don't sweat it, Line6 will help you in or out of warranty. Don't think this this is going to be a hardware issue.

 

Looks like you have tried several of the correct recovery steps. I don't see here specifically that you downloaded and installed the "HX Edit (version 2.80)" package. Perhaps you have but since that contains the driver, updater, and editor it is a better way to make sure you have them all synched up. As you indicated best to uninstall the Line6 software first at this point before reinstalling HX Edit 2.8. Once you start rolling back with separate versions of the updater and editor, etc. things have a good chance of going wonky. I would reboot the PC for good measure too. As always never have HX Edit and the Updater running at the same time as they interfere with each other's ability to recognize the Helix.

ARRRGGHHHHHHH didnt install HX Edit 2.8, I just made backup through HX 2.6 and closed that app, launched updater and it prompted that there is new firmware version available and I just went through the prompts (aka blindly clicked next) , I am so great you responded else this was going to be a bad night,

HX edit still doesnt recognize Helix but updater did, I restarted with 6 & 12 switches, and through updater trying update again

 

  • I got "Update message server started" on top left and "updating Helix Firmware" in middle of screen, on Updater
  • Now Updater prompted me Helix will reboot
  • and Helix is now "rebuilding" presets
  • Everything is finished and I just tried sound check, that 01A US Double Nrm in Factory 1 set list never sounded sweeter :) 

Thanks again @HonestOpinion

 

I guess I understand the issue now, 

  • Helix 2.8 firmware update requires "updated USB driver"
  • That updated driver comes through HX 2.8 package (I wish they decouple version numbers cause its so confusing, Helix 2.8 and HX 2.8 are not same things)
  • HX 2.8 package has latest USB drivers as well, and since, and most folks here didnt go HX 2.8 route, midway through update USB driver stopped working (it tried switching over to new driver which was not there and it couldnt continue with older driver)
  • this gives classic, bad USB cable or port signs and youtube and web forums are full of advice around that and that sends people like me on a total different debug path

 

Share this post


Link to post
Share on other sites
19 minutes ago, rijiboy said:

ARRRGGHHHHHHH didnt install HX Edit 2.8, I just made backup through HX 2.6 and closed that app, launched updater and it prompted that there is new firmware version available and I just went through the prompts (aka blindly clicked next) , I am so great you responded else this was going to be a bad night,

HX edit still doesnt recognize Helix but updater did, I restarted with 6 & 12 switches, and through updater trying update again

 

  • I got "Update message server started" on top left and "updating Helix Firmware" in middle of screen, on Updater
  • Now Updater prompted me Helix will reboot
  • and Helix is now "rebuilding" presets
  • Everything is finished and I just tried sound check, that 01A US Double Nrm in Factory 1 set list never sounded sweeter :) 

Thanks again @HonestOpinion

 

I guess I understand the issue now, 

  • Helix 2.8 firmware update requires "updated USB driver"
  • That updated driver comes through HX 2.8 package (I wish they decouple version numbers cause its so confusing, Helix 2.8 and HX 2.8 are not same things)
  • HX 2.8 package has latest USB drivers as well, and since, and most folks here didnt go HX 2.8 route, midway through update USB driver stopped working (it tried switching over to new driver which was not there and it couldnt continue with older driver)
  • this gives classic, bad USB cable or port signs and youtube and web forums are full of advice around that and that sends people like me on a total different debug path

 

 

Delighted to hear you got it worked out!

Share this post


Link to post
Share on other sites

 

btw Grammatico Jump is a killer amp, just add little Kinky Boost+ Minotaur with gains at 4.5 for both, and this amp kicks lollipop... 

Share this post


Link to post
Share on other sites
7 hours ago, PierM said:

 

Change USB port on the PC and try again.

Try all the USB ports you have before to give up.

 

The buttons are 6 and 12 (floor) for the update mode.

Share this post


Link to post
Share on other sites
17 minutes ago, kdskyy said:

Same Problem with LT  - Boot failure Entered Update Mode

HELP ME

 

Hi,

 

you need to go through all the suggestion we posted over here, with patience, and see if it works.

Share this post


Link to post
Share on other sites
41 minutes ago, kdskyy said:

Same Problem with LT  - Boot failure Entered Update Mode

HELP ME

 

If the update process stucks (...more than 30 minutes), turn off the Heilx, reinstall Helix2.8Edit(including the drivers) and start the update again. That should work.

Share this post


Link to post
Share on other sites
13 minutes ago, Peter said:

 

If the update process stucks (...more than 30 minutes), turn off the Heilx, reinstall Helix2.8Edit(including the drivers) and start the update again. That should work.

Just one suggested addition to the above.... Before reinstalling HX Edit v2.80 shut down the currently running Updater program. This program itself may be out of date; it will be replaced while installing HX Edit.

  • Upvote 2

Share this post


Link to post
Share on other sites

For what it's worth, I ran the update yesterday without any issues.  I don't know what (if any) of these factors made a difference:

 

OS:  Windows 10 x64

Helix Floor update v2.71 to 2.8

trustworthy USB cable plugged into USB 3.0 port on back of computer (didn't trust running through a USB hub or the sometimes underpowered USB ports on front)

 

Process ran exactly as the Helix instructions state over about 20 minutes or so.

Share this post


Link to post
Share on other sites

I had same problem.  Stuck at 50% overnight.  In the morning, i tried closing updater and reopening it, but it wouldn't find anything.  So I tried the posted advice:

 

If the update process stucks (...more than 30 minutes), turn off the Heilx, reinstall Helix2.8Edit(including the drivers) and start the update again. That should work.

 

Above worked.  Not sure if I really had to reinstall 2.8 Edit.  

Thanks everyone!

Kevin

Share this post


Link to post
Share on other sites
15 minutes ago, kevliao said:

...

Above worked.  Not sure if I really had to reinstall 2.8 Edit.  

...

 Probably not but it does no harm.

Share this post


Link to post
Share on other sites

Hi,  I had this exact same problem.  Helix LT was stuck on the "Failed to boot, entered update mode" screen and the only button combo that worked was 6+12.  My Line6 updater wasn't seeing that the Helix was plugged in.  Thought that it was a USB issue and proceeded to try different ports and computers.

The thing that fixed it for me was putting it into update mode (6+12 on the Helix LT) and then installing HX Edit 2.80.  Somehow this installed something that I previously did not have.  The Line6 updater was then able to see that the Helix was plugged in and I had absolutely no issues with installing the update.

Share this post


Link to post
Share on other sites
1 hour ago, silverhead said:

 Probably not but it does no harm.

Most people could just restart the update process after shut down the Helix and the updater.

This did not work for me, because the updater could not connect to the Helix anymore.

I saw, that an error occurred in the Windows device manager, so I reinstalled the drivers/HelixEdit

and the problem was solved.

...maybe not all drivers were updated correctly during the first HelixEdit installation
  • Upvote 1

Share this post


Link to post
Share on other sites
30 minutes ago, Peter said:

Most people could just restart the update process after shut down the Helix and the updater.

This did not work for me, because the updater could not connect to the Helix anymore.

I saw, that an error occurred in the Windows device manager, so I reinstalled the drivers/HelixEdit

an the problem was solved

 

Same thing happened to mine (win10 1903). Nerve-wracking while it's happening, lol.

It seems, for some people, that the new drivers and/or the updater are not installing correctly. On my system, I had the updater and hx edit installed to a non-default location. What I ended up doing was uninstalling all traces of anything related to Helix and then reinstalled everything (including drivers for devices I don't have) without changing the default location. Now when I ran the updater, Helix was recognized and the update could finish.

 

I wonder if adding an additional instruction stating to uninstall previous HX Edit installations prior to updating to HX Edit 2.80 would be helpful.

 

Share this post


Link to post
Share on other sites
8 minutes ago, duncann said:

 

Nerve-wracking while it's happening, lol.

 

for me to :) :) :)

...but good to know Helix has a "safe"mode/update mode. that makes the next update more relaxed.

 

...by the way any news about 2.9  ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...