Jump to content
Sign in to follow this  
goodpunk6

I bricked my helix rack because of 2.8

Recommended Posts

It seems that I didn't update HX edit to the latest version before updating, so now my Helix rack is bricked. It turns on but Line 6 Updater doesn't see it and can't continue the update. It sat at this screen for 3.5 hours before I finally decided to close the software and shut the helix off. What can I do to fix this?

 

QBDlsRm.png

Share this post


Link to post
Share on other sites

I literally just got it today. I worked for 30 min before I ran the update. I didn't even get to plug my guitar in

Share this post


Link to post
Share on other sites
1 hour ago, goodpunk6 said:

It seems that I didn't update HX edit to the latest version before updating, so now my Helix rack is bricked. It turns on but Line 6 Updater doesn't see it and can't continue the update. It sat at this screen for 3.5 hours before I finally decided to close the software and shut the helix off. What can I do to fix this?

 

QBDlsRm.png

 

You'll probably be just fine, I wouldn't get too concerned yet. Assuming you got backups initially, start by following some of the remedies in this thread. The first thing I might try is scrolling down past the "Flash Memory" file and "downloading the "HX Edit (version 2.8)" file instead, install it, and then restart the Updater and follow the update instructions.

  • Like 1

Share this post


Link to post
Share on other sites

you said this thread?? which thread?

 

I made no backups because it is brand new. Nothing to backup.

Share this post


Link to post
Share on other sites
42 minutes ago, goodpunk6 said:

you said this thread?? which thread?

 

I made no backups because it is brand new. Nothing to backup.

 

I believe he was referring to this thread

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I was stuck at 50% too. I restarted the updater - no luck. Restarted Helix and it wasn't detected by the updater. I ended up uninstalling all Helix related software and then reinstalled Line 6 Updater and HX Edit. Rebooted my PC and started up the Helix - it got detected and I was able to redo the update no problem. 

  • Like 2

Share this post


Link to post
Share on other sites

Here is a link to many suggestions that have been helpful

 

 

Hopefully this is helpful for you ... just read it all then find the one that best fits your issue

Share this post


Link to post
Share on other sites
1 hour ago, goodpunk6 said:

you said this thread?? which thread?

 

I made no backups because it is brand new. Nothing to backup.

 

37 minutes ago, lungho said:

 

I believe he was referring to this thread

 

 

+1 I was indeed, thanks for the assist lungho.

Share this post


Link to post
Share on other sites

Had the same problem on my Rack hung at the half way mark tried everything reinstalled drivers HX Edit Updater still wouldn't detect the unit only thing that worked was charged USB ports on the PC and boom re detected and installed the update  

Share this post


Link to post
Share on other sites
7 hours ago, proceedeth said:

I was stuck at 50% too. I restarted the updater - no luck. Restarted Helix and it wasn't detected by the updater. I ended up uninstalling all Helix related software and then reinstalled Line 6 Updater and HX Edit. Rebooted my PC and started up the Helix - it got detected and I was able to redo the update no problem. 

 

I am one of only (I am sure) a handful of people who have had the same problem as described above, ie stuck at 50%, which may have been because I did not follow instructions and update the HX Edit. I have followed the instructions as per above and it worked like a charm. I am happy that this has been out with the Beta people and things like this have gotten ironed out. Now I must plunge in and see whats new.

Share this post


Link to post
Share on other sites

uninstall all previous hx edit, hx usb drivers, all updaters. install hx2.80. launch updater. that should solve. it least did for me, I was having exactly the same notorious "50% problem"

Share this post


Link to post
Share on other sites
4 minutes ago, requietus666 said:

uninstall all previous hx edit, hx usb drivers, all updaters. install hx2.80. launch updater. that should solve. it least did for me, I was having exactly the same notorious "50% problem"

 

solved the problem for me too

Share this post


Link to post
Share on other sites
On 7/18/2019 at 9:21 PM, proceedeth said:

I was stuck at 50% too. I restarted the updater - no luck. Restarted Helix and it wasn't detected by the updater. I ended up uninstalling all Helix related software and then reinstalled Line 6 Updater and HX Edit. Rebooted my PC and started up the Helix - it got detected and I was able to redo the update no problem. 

 

I also had this exact problem and thought my Helix Rack would have to be sent back to Line 6 to repair. As a last resort I tried the above method and it worked perfectly!

as a side note, the update itself only took 5 mins or less, not counting the presets rebuilding. 

Share this post


Link to post
Share on other sites

Just wondering if some of these update problems happened because the updater wasnt updated by some people? https://line6.com/software/index.html

.NOTE: Installing HX Edit 2.81 automatically installs the latest version of Line 6 Updater, which is required to update the firmware.So maybe installing the 2.80 with out the newest updater might have caused some problems?

 

Share this post


Link to post
Share on other sites
13 minutes ago, cgar18 said:

Just wondering if some of these update problems happened because the updater wasnt updated by some people? https://line6.com/software/index.html

.NOTE: Installing HX Edit 2.81 automatically installs the latest version of Line 6 Updater, which is required to update the firmware.So maybe installing the 2.80 with out the newest updater might have caused some problems?

 

 

Hi,

 

Possibly not that, because when it installs it replaces the previous version. Most of this stems from plain ignorance. Most of these people who scream and shout that “Line 6 has bricked my Helix”, simply either didn’t read or wilfully ignored the installation notes, which quite plainly stated in very large letters: 

 

STEP 2—Updating HX Edit to 2.81 (YOU MUST DO THIS BEFORE UPDATING YOUR HELIX/HX FIRMWARE!)
Clear enough for me to take note of, but many simply did not follow it.
 
The other main fault was because people, once again, failed to take note of this:
 
"halfway through the update process, Line 6 Updater displays a second dialog and Helix's LCD reads "Boot Failure. Entered Update Mode!" THIS IS NORMAL. DO NOT FREAK OUT, TAKE A PHOTO, AND THEN POST IT ONLINE BECAUSE EVERYONE WILL MAKE FUN OF YOU FOR NOT READING THESE INSTRUCTIONS."
 
There were genuine issues with some Windows computers having problems with the drivers, which apparently got screwed up as Helix had one brain removed and a new one inserted.
 
Amazingly the people who scream that Line 6 killed their hardware fail again but not apologising for their own stupidity. What makes even more ridiculous is the fact they are installing software - if it doesn’t work you can always overwrite it, it doesn’t burn out your circuit board.
 
Line 6 have nothing to gain by damaging their own product and it is ludicrous to even think that. 
 
I have stated this before but I will say it again - Nothing is foolproof to a sufficiently talented fool!
 

Share this post


Link to post
Share on other sites

If anyone is having problems with the installation on a Window machine I would recommend they take a few minutes to watch this video which may help. Send them to watch this.

 

I should have put this link in here a long time ago but I would have thought that others would have found it before now - Anyhow it saves me from doing a lot of typing.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...