Jump to content
justinlf84

Helix Floor 2.8 sending midi signal on patch switch

Recommended Posts

When I've got my Helix connected to ableton, every time I select a new patch, it sends a pitch bend signal to ableton, which makes programming buttons across multiple patches really obnoxious. Any idea how to stop this from happening?

Share this post


Link to post
Share on other sites

In Globals-MIDI turn OFF PC Send.

By default, on preset load, Helix sends:

 

MSB 0 Value 0

LSB 32 Value Current Setlist # (0-7)

Helix MIDI Preset# (0-127)

 

It used to also send CC#61, but that appears to have been fixed in 2.8.

 

If you turn off PC Send, it sends nothing.

 

If you're still having that problem, use a MIDI monitor tool like MIDIOX (or whatever the MAC equivalent is) to find out what it's actually sending.

There might be a monitor tool in Ableton, I'm not sure.

You might have to do a complete Factory reset to solve the problem, but first find out exactly what the problem is. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×