Jump to content
Sign in to follow this  
Meiannatee

2.80 Bug when controlling multiple parameters with footswitch

Recommended Posts

There seems to be a bug with assigning multiple control parameters to a footswitch.

 

Setup:

Assign a footswitch to toggle between 2 settings in a delay block:

(A) Low feedback + low mix

(B) High feedback + high mix

In Global Settings > Preferences, snapshot edits set to "Recall".

 

Problem:

Helix gets "confused" about the ON and OFF states of the footswitch. This typically happens when changing snapshots.

 

Description:

1) Select Snapshot 1. Press footswitch  > ON. Parameters set correctly to (B), footswitch lights up.

2) Switch to Snapshot 2. Press footswitch > ON as well. No issues so far.

3) Switch back to Snapshot 1. Sometimes this bug occurs: press footswitch again > it goes from ON to OFF, but parameters jump from state (B) > (A) > (B). Parameter states are (B) but footswitch light shows OFF, meaning states are reversed.

4) Switch back to Snapshot 2. Footswitch functions normally, with ON corresponding to state (B).

5) Switch back to Snapshot 1. Footswitch behavior still reversed (ON = state (A))

 

This setup was working fine before the update. It started after updating to 2.80. I've tried this on a new preset, same problem happens occasionally. But not always. Sometimes restarting the unit fixes it for awhile. Can anyone verify?

Share this post


Link to post
Share on other sites

Well, when you use a footswitch as a controller, it doesn't necessarily have on/off states. It has min and max settings. Generally, the max corresponds to the footswitch being activated and the LED ring lighting up, but with snapshots, it's easy for things to get mixed up. One thing is that each snapshot can by saved with a specific value for that parameter outside of the footswitch state. So using this footswitch with the Snapshot Edits parameter set to Recall, you're actually re-saving the snapshot value whenever you use the footswitch. The footswitch is really just always going to toggle between the min and max settings. It doesn't really track with snapshot changes. That's been my experience, anyway.

Share this post


Link to post
Share on other sites
6 hours ago, phil_m said:

Well, when you use a footswitch as a controller, it doesn't necessarily have on/off states. It has min and max settings. Generally, the max corresponds to the footswitch being activated and the LED ring lighting up, but with snapshots, it's easy for things to get mixed up. One thing is that each snapshot can by saved with a specific value for that parameter outside of the footswitch state. So using this footswitch with the Snapshot Edits parameter set to Recall, you're actually re-saving the snapshot value whenever you use the footswitch. The footswitch is really just always going to toggle between the min and max settings. It doesn't really track with snapshot changes. That's been my experience, anyway.

Thanks for the reply. What I meant was, previously, the behavior was predictable as such:

Footswitch ON (LED ring lit up) = max settings

Footswitch OFF (LED ring off/dim) = min settings

 

Now, in the same preset, it could be working normally in one snapshot (like the above), but reversed in another (ON = min, OFF = max).

 

I know it's a bug because:

1) it worked in previous version

2) sometimes restarting the unit fixes it for awhile

Hope that clarifies the matter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×