Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Boot Failure. Entered Update Mode


Recommended Posts

While updating my Helix floor, it gave me "Boot Failure. Entered Update Mode" message on the pedal. After waiting half an hour it was still the same, so I canceled the process.

Upon Rebooting the HELIX same message showed up again and again. I tried changing usb cables and usb ports on my pc and it still did not work. 

WHAT IS HAPPENING? I need my pedal back :( Help!

Link to comment
Share on other sites

9 hours ago, rafman21 said:

WHAT IS HAPPENING? I need my pedal back :( Help!


Simple answer.




Further more, when you post on this forum looking for assistance, it’s a great help to know what Computer and OS you are using. Although, I will guess - PC running Windows? This issue is usually associated with Windows Drivers.


You could try the suggestion, most helpfully supplied by “Peter”, in the post above.


In his comment, he mentions that this has been discussed many times, whereas I would state that it is more like hundreds of times.


Don’t panic - you will get your pedal back. ;-)


The answer is out there, all you need to do is look, but as you appear incapable of following instructions...



 This thread has over 120 replies and over 8,800 views. Took less than a minute to find!



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...