Jump to content
toobhed

Is it Possible to Toggle More Than One Color Per Footswitch

Recommended Posts

My goal is to create an A/B switch for Clean/Crunch tones.  I would like to have the switch set to red on crunch and blue on clean.  So far I am only able to assign one color for the first state, and then color is not lit for the second state.

 

With more features come more for the wish list.

Share this post


Link to post
Share on other sites

Use a low DSP effect like a Gain Block set to 0.0db assigned to the same footswitch, saved in the opposite default Bypass condition as the Clean/Crunch switch.

  • Upvote 1

Share this post


Link to post
Share on other sites
1 minute ago, rd2rk said:

Use a low DSP effect like a Gain Block set to 0.0db assigned to the same footswitch, saved in the opposite default Bypass condition as the Clean/Crunch switch.

 

Great tip.... I'll have to try this myself!

Share this post


Link to post
Share on other sites
Just now, codamedia said:

 

Great tip.... I'll have to try this myself!

 

I haven't tried it myself, hope it works! :-)

I often use an amp with the FX Loop Block. When the Loop is ON and the Amp is  OFF the LED is Lt Blue. Loop Off/Amp On it's RED. So it SHOULD work.....

Share this post


Link to post
Share on other sites

Well, I can't seem to get this behavior.  Every time I customize the color of the footswitch it overwrites the previous setting.  I created two 0db gain blocks, set one to on and one to off.  I selected the on block, assigned footswitch and color.  Then I went to the off block and did the same thing.  Both blocks change states when the footswitch is pressed, but it seems that changing the color on either block will cause the switch to use only that color.

 

Is this the method you use?

Share this post


Link to post
Share on other sites

My apologies! I could have sworn I had that working at one time, but if so, I can't find that preset.

Anyhow, I can't make it work now, so the answer to your original question would be, AFAIK, no, you can't use different colors on a single footswitch.

Share this post


Link to post
Share on other sites

No luck trying that on my end either.... 

I can toggle between effects... but the LED is either on or off (or on/dim depending on global settings)

 

Are we all running a 2.8 variant of firmware? Perhaps this is something that worked on a previous version.... even if it wasn't intended? 

Share this post


Link to post
Share on other sites

As I recall, that's the only way it has ever worked; one state is lit up, the other is dim/same colour.

 

Interesting possible option, though I don't know if I'd want to give up any horsepower for that feature if it introduced any unintended lag anywhere else.

 

Share this post


Link to post
Share on other sites
2 hours ago, codamedia said:

No luck trying that on my end either.... 

I can toggle between effects... but the LED is either on or off (or on/dim depending on global settings)

 

Are we all running a 2.8 variant of firmware? Perhaps this is something that worked on a previous version.... even if it wasn't intended? 

 

I know i had it working that way at one point, entirely by accident, because when I saw it I thought it was way cool!

If I figure it out I'll post back.

Maybe it was a bug.......:-)

Share this post


Link to post
Share on other sites

Not exactly what you are looking for but right now your best option might be to use snapshots with the effects you want active . The LED rings can be assigned custom colors for each snapshot and its respective footswitch.

 

Note: In the 2.81 firmware when you are editing the preset the snapshot's custom color you assign in HX Edit(right-click on the snapshot name to select color) will not be reflected in the LED ring until you save the preset(at least with my particular combination of global settings). Switching away from and back to the snapshot with your custom color will also cause it to display the new color.

  • Thanks 1

Share this post


Link to post
Share on other sites
24 minutes ago, HonestOpinion said:

Not exactly what you are looking for but right now your best option might be to use snapshots with the effects you want active . The LED rings can be assigned custom colors for each snapshot and its respective footswitch.

 

Note: In the 2.81 firmware when you are editing the preset the snapshot's custom color you assign in HX Edit will not be reflected in the LED ring until you save the preset(at least with my particular combination of global settings). Switching away from and back to the snapshot with your custom color will also cause it to reflect the new color.

 

EXCELLENT! I totally forgot you could do that! Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×