Jump to content
MadScientistDude

G30 quit working after 4 months.

Recommended Posts

I bought a G30 in May and it no long works. The transmitter light does not come up. I've put new batteries in. The receiver light also does not turn on. Thanks in advance.

Share this post


Link to post
Share on other sites

Does it power up if you press on the battery door? I've literally replaced that component 4 times on my G30. Recently took it off my board because its basically useless in rooms with more than 10 people or places with modern mixers that have Wi Fi for tables (including the ones I have in my band racks for IEM setups) as it gets a TON of interference from anything Wi Fi. The only way I could use it was if I plugged it into a 20' cable and moved the receiver way off stage away from lights/gear/cell phones, which kind of defeats the purpose of a wireless if I still have to run an extra cable for it every time. I'm going back to UHF for the time being and dealing with the noise because the dropouts were way more annoying that a little noise.

  • Like 1

Share this post


Link to post
Share on other sites

You are correct, the transmitter only lights up if I push hard on the battery door and even then the two lights blink on and off as if there is an error code. Its really frustrating because my G10 is range limited. Nothing close to advertised no matter what environment, and for the 2 gigs that this G30 worked I barely got a few more feet of range. With all the problems people are having I'm surprised the Relay division is still in business. And here it is 2 months after the post and not a peep from a Line 6 representative on this official Line 6 forum. 

Share this post


Link to post
Share on other sites

My G10 was fixed once under warranty the same week I bought it for the flimsy USB connector issue then replaced towards the end of the warranty after it just quit working.

 

Share this post


Link to post
Share on other sites

Don’t expect Line 6 to be active here, they don’t consider this an official support forum, just a user support forum. I think what it comes down to is the 2.4ghz band is full to capacity, and they know about the g30 issue, that’s why the battery cover is available by itself from full compass. 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the info! I took a careful look at the battery door and found that the metal plate that acts as the connector between the battery poles and holds the lock in place was floating. The factory didn't melt the plastic bosses to hold the thing together. Of course is seems to have other issues as well. I put in for a warranty repair. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×