Jump to content

Problem with HX Stomp and BOSS FS-7 footswitch


mr_slugworth
 Share

Recommended Posts

I'm trying to get a BOSS FS-7 footswitch to work with my HX Stomp, Firmware 2.82. I'm using a TRS cable, FS-7 running passive set to momentary mode.

 

When I hit either switch on the FS-7, the preset changes correctly at first and stays there for about a second, then it starts scrolling quickly through the presets. I am just expecting it to scroll one preset per footswitch press. Any ideas on there about what I could be doing wrong? Are BOSS footswitches not compatible? AFAIK the FS-7 is the same internally as the FS-6, but in a vertical (rather than horizontal) form factor.

 

In HX Edit I set the following in Preferences > Device Settings:

 

EXP/FS Tip: FS4

EXP/FS Ring: FS5

FS4 Function: Preset Up

FS5 Function: Preset Down

  • Like 1
Link to comment
Share on other sites

  • 1 month later...

I had the same problem with a new FS-6 switch. I can't remember how I solved I just know the settings I used on the FS-6 at the end were completely 'wrong' when it worked. I think, I set it to latch instead of momentary.

It's worth to ingnore the labels on the Boss and just try what works. The possibilities are not endless.

Link to comment
Share on other sites

The polarity values must match to get it working correctly.

 

FS-6 settings:

Polarity:RIGHT, Mode:LEFT (momentary). This goes for both A&B switches.

 

HX Stomp  settings:

Global settings/Preferences/  EXP/FS Tip:FS4, EXP/FS5 Ring:FS5, Tip Polarity:Normal

Global settings/Footswitches/  FS4 function:PresetUp, FS5 function:PresetDn

 

 

Configured in this way, the FS-6 never becomes unresponsive. 

It still does scroll when hold, but in a controlled way.

Any other settings may cause unexpected behaviors.

Link to comment
Share on other sites

I know the post is a couple months old, but that's sounds like a wrong setting on the FS-7. There isn't much to those, they are just basic operation - providing you have the options set properly. 

 

Both switches must be set for momentary. If set to latch... it would be the same as pushing and holding it down. 

If they still scroll - reverse the polarity. Do this on both switches and make sure both switches are set to the same polarity!

 

Link to comment
Share on other sites

  • 1 month later...

Hi,

 

     I had exactly the same problem with my FS7 foot switch. But I think I've just fixed the issue.

 

     Apart from setting the EXP/FS to FS4 and FS5, I changed the 'TIP POLARITY' to 'Inverted' and the 'RING POLARITY' to 'Inverted'. They were both previously set to 'Normal'.

 

     Just to clarify, this is in 'Global Setting' under 'Preferences'.

 

     As far as the foot switch, it seems to work if the polarity is set to l or ll. And of course it's set to Momentary. 

 

     Now my FS7 is working fine.

 

    Hope that helps!

 

    

  

  • Like 1
  • Thanks 2
  • Upvote 1
Link to comment
Share on other sites

  • 1 month later...
On 12/12/2019 at 5:39 AM, dodec1212 said:

Hi,

 

     I had exactly the same problem with my FS7 foot switch. But I think I've just fixed the issue.

 

     Apart from setting the EXP/FS to FS4 and FS5, I changed the 'TIP POLARITY' to 'Inverted' and the 'RING POLARITY' to 'Inverted'. They were both previously set to 'Normal'.

 

     Just to clarify, this is in 'Global Setting' under 'Preferences'.

 

     As far as the foot switch, it seems to work if the polarity is set to l or ll. And of course it's set to Momentary. 

 

     Now my FS7 is working fine.

 

    Hope that helps!

 

    

  

 

Huge thanks! Now it's working!

Note that the FS-7 needs to be connected using jack B, and its polarity switch setting doesn't matter.

Link to comment
Share on other sites

  • 6 months later...
On 12/12/2019 at 1:39 PM, dodec1212 said:

Hi,

 

     I had exactly the same problem with my FS7 foot switch. But I think I've just fixed the issue.

 

     Apart from setting the EXP/FS to FS4 and FS5, I changed the 'TIP POLARITY' to 'Inverted' and the 'RING POLARITY' to 'Inverted'. They were both previously set to 'Normal'.

 

     Just to clarify, this is in 'Global Setting' under 'Preferences'.

 

     As far as the foot switch, it seems to work if the polarity is set to l or ll. And of course it's set to Momentary. 

 

     Now my FS7 is working fine.

 

    Hope that helps!

 

    

  

This is the solution, thank you. Bought an FS-7 today and it just kept scrolling even though it was set to momentary. Inverting the tip and ring polarity in the settings is the trick.

Link to comment
Share on other sites

  • 11 months later...
  • 3 months later...
On 12/12/2019 at 8:39 PM, dodec1212 said:

Hi,

 

     I had exactly the same problem with my FS7 foot switch. But I think I've just fixed the issue.

 

     Apart from setting the EXP/FS to FS4 and FS5, I changed the 'TIP POLARITY' to 'Inverted' and the 'RING POLARITY' to 'Inverted'. They were both previously set to 'Normal'.

 

     Just to clarify, this is in 'Global Setting' under 'Preferences'.

 

     As far as the foot switch, it seems to work if the polarity is set to l or ll. And of course it's set to Momentary. 

 

     Now my FS7 is working fine.

 

    Hope that helps!

 

    

  

I can confirm that this last piece, changing the TIP POLARITY, works for my FS7 - it is now behaving as it should be when connected to the HX STOMP.  Many thanks dodec1212!! 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...