Jump to content

Spider V Firmware - v2.00 - no real update happened

Recommended Posts

After connecting my Spider V 60 to Android "Spider Remote"  application, there was a new device firmware update  v2.00 , so I ran it. After “downloading from server” message nothing happened, in spite of a preceding “how to”  messages saying how device will be processing new SW and restarting etc…. Neither  Android app nor device was frozen, everything worked as before, but no upgrade happened. 

What is wrong with it ?

Share this post

Link to post
Share on other sites

Welcome to the world of mobile devices, everyone has a different result when it comes to Android.    Don't get me wrong, I have a OP 7 Pro and previously a Samsung S9.    I've always ended up using a PC to update my amp.    


First make sure the Spider Remote application is up to date, I'm amazed how many phone users don't regularly update their phone and applications.   I currently have version 2.0.0 build 128.


Just checking now, the 2.0.0 build 128 version of the app works for all functions for me except for the Device Flash.   I'm running the Android 10 open beta at this time, so it's possible there was enough changes to the Android OS to allow Spider Remote to work for 95% of the features but fail for flash.


If you have access to a computer, I'd recommend that for your flash updates for now.   I use my phone along with a supposedly Kevlar braided cable for durability to do any adjustments pre-gig.  The cool thing?   I really don't have adjust as much with the 2.00 firmware and the classic speaker setup.  Rest I do using my FBV 3 during the performance.

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now