Jump to content
IMMikeMurphy

Stuck in Snapshot Mode

Recommended Posts

Since updating to firmware 2.80, my Helix will randomly get stuck in snapshot mode.

(in)conveniently enough it always happens right as we're taking the stage.

 

Once stuck in snapshot mode like this, there's nothing I can do on the Helix to get it out of that mode and I'm stuck with one sound for the whole gig turning my $2000 Helix into a nearly useless box.

 

Please tell me there's a fix. I'm happy to receive another Helix to see if it does the same thing but I know I cannot continue like this.

Share this post


Link to post
Share on other sites

This is a bug that was fixed with the 2.82 firmware.

Share this post


Link to post
Share on other sites

As mentioned in this post, getting stuck in Snapshot mode still occurs for me in firmware 2.82. L6 support had me do another full factory reset, but that hasn't resolved the issue. At this point, I'm not sure what to do.

 

@IMMikeMurphy, can you let us know if this resolves for you after updating to 2.82?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...