Jump to content
REI_ARTHUR

POD HD500x EXP pedal not sweeping values (not cal) Tech help

Recommended Posts

Hello, everyone.

 

I would like some help from the tech guys. My Expression pedal stopped working. At first, it started to roll back to heel position constantly (0%) by itself. Now it's completely stuck on 0%. So i can't use it to control anything. If i assign it to a volume pedal the patch will go completely silent, for instance. The pedal switch is working normally and is changiing from EXP 1 to EXP, as it should. It just won't sweep, even when at pedal cal. screen. I've tried to flash it again with no luck, so it's probably hardware.

After fighting it, I had it opened by a tech friend. He said the probable cause is an optical sensor pair malfunction. He said i should take it back to him when he has the time to work on it, but gave me  the green light to research the part beforehand just in case he comes to the same conclusion after examination at his shop.

So here i come... does anyone know the correct specs and ID for the part and where i could get it??? I attached some pics to help. Thanks !!!!!!

 

20191023_163033.jpg

20191023_163036.jpg

Share this post


Link to post
Share on other sites

The part you're looking for probably is the phototransistor Optek OP580..

I know they worked good as replacement for the POD X3L pedal optical sensors, and I strongly suspect that they would work perfectly on the HD500X too.

 

op180_280.jpg

 

datasheet

 

 

As a possible fixing you could also try to heat the not working optical sensors with a hair dryer for 1 minute or 2..

 

Who knows?.. It could work.

 

Also, make sure the cable plugs from the pedal pcb to the motherboard are firmly seated.

 

_______________________________________________________________________________________________________________________________________________________________________

All about POD HD500/X

help and useful tips

 

  • Upvote 1

Share this post


Link to post
Share on other sites
On 10/23/2019 at 7:33 PM, REI_ARTHUR said:

Awesome!!!!!!!!!! Thank you so very much!!!!!!!!!!!!!!! I really appreciate it.

Hi there, could you fix your pedal? Please give us more details.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...