Jump to content
Stratojoe17

HX Stomp Latency

Recommended Posts

I am impressed by my new HX Stomp. As I was used to playing directly into the amp before, 

I can now hear some latency. It's not much but not nice. 

 

Whats the best way to reduce latency to the maximum. Which effects heavily affect latency ?

Any recommendations you could give ?

 

Thx

Jo

Share this post


Link to post
Share on other sites

If you're plugged directly (by cable) into the Stomp, which is plugged directly into your amp or powered speakers, there should be no more than 1.8ms latency which is, IIRC, the time it takes to convert your analog signal to digital and back.

Share this post


Link to post
Share on other sites
47 minutes ago, Stratojoe17 said:

1,8 ms regardless of the amounts and types of effects used ?

 

AFAIK

Share this post


Link to post
Share on other sites

Sound travels roughly a foot in a millisecond.  1.8 ms is the latency you would experience if your ears were ~2 ft from the speaker.  If it is worse than that something else is going on.

Share this post


Link to post
Share on other sites

From all I remember, the general latency of the Helix family is indeed around 2ms (should take the time to measure it myself, but it seemed correct to me). However, someone from the Line 6 team somewhere said it could as well be a tad higher on certain patches - but IMO it should never really get in the way.

However, if you really feel a noticeable latency (unless you are Donald Fagen who is supposed to hear timing offsets of just some samples, no idea whether that's true or just an urban myth), do you by any chance have some questionable IRs in use? I noticed some of the free ones floating around to be trimmed rather poorly - and even just 1024 samples at 48kHz give you plenty of room for additional latency (21.3333333...ms to be exact). If that's not the case, you might as well be Mr. "In The Pocket" (which isn't a bad thing at all). Or it's something else which goes wrong.

Share this post


Link to post
Share on other sites

I knew that 1,8 ms are not noticeable.  No questionable IRs  installed. The unit is brand new. 

 

Thanks for your answers!

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...