Jump to content
Sign in to follow this  

Getting Native to see Midi input from Reaper

Recommended Posts

I am trying to set up a small practice rig with Native (I own a Floor for Live performances).


Using Native with Reaper, and works fine, and am now trying to set up a small midi keyboard (Alesis Q25) to allow me easily to change snapshots , Bypass blocks etc. If I can get this working I might consider Midi Floor controller.


So I have read the official L6 info on it(which is very limited) quite few posts on the Net about setting up, as well as the Helix Native Pilots guide, and am stuck at the point of getting the Native VST to see any Midi input (The lower right status bar  "Midi In" not seeing anything).


From the Native Pilots guide on page 47 I am stuck on this part:


Additionally, it is often necessary to configure your DAW host track routing to so that the external MIDI Controller data is fed directly to your current Helix Native plug-in instance. This often requires the use of a MIDI or Instrument track to receive the MIDI input and then route it to the audio track on which the Helix Native plug-in inserted. Please see your application's documentation for details. TIP: On the plug-in’s Status Bar, at the lower right of the main window, you’ll see a handy MIDI In indicator light. When Helix Native receives MIDI input, you’ll see this light up green—which can be a big help


I have a separate track setup for the Midi keyboard and then its routed to my Native track.  Problem is Native does not appear to see my Midi commands being sent, as the NAtive VST is not showing any response on that "Midi In" icon in Native.


Any help would be appreciated.





Share this post

Link to post
Share on other sites

Hi.  This is how I have done it in Reaper (DAW).

I use a Tablet with an app called BandHelper to use as a controller.

The tablet is connected to my UMC204HD audio and midi interface, using a cheap USB to MIDI cable. 

The UMC204HD is then connected to my laptop through its separate USB cable.


Open Reaper (DAW) and make sure that you have configured your MIDI and AUDIO in the Preference settings.  In the midi section, make sure that both the MIDI interface (in my case the UMC204HD) and the Computer's MIDI interface are both showing Enabled+Control.

In Reaper, create an Audio track.

In the audio track, insert Helix Native.  Now plug your guitar in and select different Presets, Snapshots... Play the guitar.  You should be getting sound out of it.  If not, check that the track is RECORD ARMED and MONITORING ON.


Now insert a new track and put it above the Audio track.

In the Input field, choose MIDI and select your MIDI device (in my case the UMC204HD), select All Channels.

On the same track click the I/O button.

Click on the Midi Hardware Output and select your COMPUTER Midi device.

On this MIDI track check that the track is RECORD ARMED and MONITORING ON.

Send the Midi track to the Audio track by click-drag the midi track's I/O button onto the Audio track.


You don't need to create a Midi Item for the track if you want to use it in live situations, so no programming.


Save your project!!!


Now use your programmed MIDI Controller with the Helix Native.  You should see the Green circle, lighting up at the bottom right of the Helix Native Plug-in, every time a Midi message is received.

It works for me just fine for controlling Snapshots, but not for Program Changes!  I believe this is not yet implemented.  ...unless someone has a solution for it?


Let us know how the outcome.  




Share this post

Link to post
Share on other sites

Useful info for Reaper users, thanks!


I don't use Reaper, but FYI ... Native now supports Program Changes. In Logic, though, I have to use Native as an plug-in in an Instrument track rather than an Audio track. Then its a matter of getting audio in, and recording the audio. For Reaper, I'm not sure how that is done. Maybe this thread would be helpful for that: https://forum.cockos.com/showthread.php?t=153147



Share this post

Link to post
Share on other sites

Still stuck.  I am not sure what the issue is but sure its my lack of understanding Midi. 


Reaper is seeing all my keypresses on my Midi Controller (Alesis Q25 keyboard) - verified by running ReaControlMidi and logging of keypresses.  For example I press the lowest key on the keyboard and it reports back note 48, etc.  But when in Native the status bar (lower right "Midi In" light) will not see these presses ,except for when I move the Modulation wheel(CC1) or Pitch Wheel - nothing else responds.  I was able to assign a block on and off to that CC1 that I know Native is seeing so Im close.  Just cant figure out why none of the keys are being seen.  I thought maybe it was because of Hardware Control mode being on and reserved CCs but that's not it as I tried ones not reserved with no luck and also tried turning off HC but still no joy. 


I could be wrong but since Reaper is seeing all my Midi keypresses, shouldnt it be as easy as setting a Bypass on the same note value as the keyboard is sending.  Are note values the same as CC, or is there something I am missing.  I also tried reassigning CCs via JS MIDI Mapper but that led nowhere.


Just stuck and the issue is the Line6 support on MIDI is very sparse and this appears to be something on that side, and not Reaper, so not sure who can help.


Share this post

Link to post
Share on other sites

I was able to get it all working by using the plug-in ReaLearn, that allows me to reassigning note values to CC codes.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...