Jump to content
themetallikid

Corrupted preset(s)

Recommended Posts

hi guys,

here is a new "log" of the problems I encountered today, I submitted this inside my ticket to line 6, still no reply from them

my day was going to be dedicated to try some fremen and mbritt presets that I bought months ago but I spent it to track down the problem... not as much fun...

 

but the "not-so-bad" things are that

1) in the end you can always overcome the problem IF you have backups

for example I now saved a setlist with fremen &mbritt presets so that I can reload it easily

and

2) it seems that a factoy restore is enough to solve the issue (I didn't reinstall hx edit nor the firmware)

 

also read the comment I made at the end of the "log", maybe dragging many presets is one of the main problems, I don't know

 

here it is:

 

 

ok, this time I overwrited one of the factory setlists with an empty one

I imported some presets by fremen and mbritt (created and purchased before the 2.82 upgrade and used without problems before the upgrades, I think in 2.54 or 2.60)

 

after the 54 fremen presets finished importing,

hx edit behaved strangely: it switched by itself to another setlist but showed inside that setlist the names of the presets I just imported

it seemed like just a visual bug because switching setlist again solved the visual issue

 

then I imported the 32 mbritt presets on the same setlist and it gave me many subsequent -8207 error windows like the one in the screenshot "200416a"

and helix floor was freezed on a black screen

 

switching helix off & on automatically rebuilded the presets (apparently only the new ones)

 

then 6 of the imported presets had strange names, see attachment "200416b"

also I noticed that not all the 32 presets were imported

they stopped at preset slot 81 (see below)

 

 

again:

I overwrited the same setlist with an empty one

I imported the presets by fremen

this time no visual issues (the difference is that the first time before importing to setlist 2 I was onto a a preset from setlist 6 to which the helix visually switched to at the end of the import, while this time I was on the same setlist of the import)

 

then I switched helix off and rebooted holding FS 10+11 for presets rebuild

(here I exported the v.2.82 rebuilt fremen presets just to be safe)

and then I imported the mbritt presets:

 

got exactly the same problem !

 

switching helix off & on automatically rebuilded the presets (apparently only the mbritt ones)

 

then the strange names seemed gone... so I though to import the remaining 12 mbritt presets one by one but got the same error/freeze, at the first import

(I believe it was on slot 82)

 

 

so again:

I overwrited the same setlist with an empty one

then this time I imported the presets by mbritt: everything fine

which tells us it's not the presets that have a problem

 

then I imported the fremen's that I had just exported after rebuilding them:

again errors (I counted 46 windows of error -8207)

and helix black screen freeze

 

switched helix off & on

I noticed that of the fremen presets, the last 11 were not imported,

presets from n. 82 and over look like empty "new presets"

but actually the n. 82 is not empty, it has blocks in it (but it's not the preset that was supposed to be there)

 

I tried to export presets from 82 and over by dragging them but it won't do it (without warning or errors)

exporting them with the export command gave a multiple error -4 window (see "200416c.png" there you can see I'm on a "new preset" but with blocks in it) and exported some presets:

I put the exported presets in the folder "200416c" where you can see that 5 presets are missing (the five -4 errors of the snapshot) and the one without number should be the "82 empty-non-empty" because it's the fist one exported and because it's the only one which weights 20KB;

 

I checked that if I export from 88 to the end of the setlist, jumping the 5 faulty presets, the export works

 

I then imported the last 11 fremen presets jumping the 5 faulty slots... and it worked!

 

as a side note:

before exporting, I tried to overwrite preset 82 with an empty one and got error "-4" (see "200416d.png")

but the empty preset that I used was actually one of the 5 faulty presets,

then, after realizing that, I tried with another "safe" empty preset and it deleted the content of the "non empty" preset and didn't give me an error but the name didn't change to New Preset in the setlist but only in the top part of hx edit (see "200416e.png")

 

anyway then I tried the reboot while holding FS 11 + 12 to clear the "82 non empty preset" and that leaved the preset name in the setlist unchanged in hx edit but not on the helix hardware where everything looks ok (see "200416f.jpg")

 

then I did the reboot while holding FS 11 + 12 to clear the other 5 faulty presets with hx edit closed

then I lauched it ...the 6 faulty presets are all still with their names (that I gave them after they got corrupted)

 

ok time for a reboot holding FS 10+11 to rebuild all presets... no luck the faulty presets were not cleared, instead the non empty preset got his name in the "header" too ("200416g.png")

 

so I tried to overwrite the 6 presets with empty ones: error -4, helix freezed to black screen and then error -8207 (see "200416h.png" and "200416i.png")

 

then:

helix factory reset (9+10 FS pressed on boot),

then I moved some presets just over the 82-87 slots of the factory presets 2 setlist ...no problem

then I wiped the setlist (overwrited with an empty setlist)

 

then I loaded the mbrit presets

and the fremen just up to n 81

then the last 11

...no problem

 

then I wiped the setlist again

and loaded the mbrit presets

and then all the fremen's ...no problem (they go up to 93)

 

 

then I loaded my last "supposedly working" full backup excluding the factory 2 setlist

 

for now everything seems to work, we will see...

 

I hope I gave you enough material to narrow down the bug

 

for me it's clear that I need to avoid copying, pasting, moving and importing many presets at a time, ...

maybe only dragging gives problems... next time I'll try to use import/export and copy/paste commands instead...

 

thanks,

Lorenzo

Share this post


Link to post
Share on other sites
1 hour ago, perapera said:

maybe only dragging gives problems... next time I'll try to use import/export and copy/paste commands instead...

 

just to let you know that I modified some fremen presets and I felt like reordering some of them and I decided to do it this way:

export of all the presets by selecting them and using the white "export" command in hx edit

 

renamed the files in the finder so that they were in the right order alphabetically

reimported to hx edit again with the white "import" command ...it worked!!

 

this is the same setlist and presets and preset slots with which I had all the problems I described in my previous post

 

seems like: no dragging no freezing (fingers crossed) ;-)

Share this post


Link to post
Share on other sites

when I had my issues with corrupted slots, it was around the 82 mark as well.  Sometimes I'd be rearranging a setlist for an updated setlist for my band, and I'd be working up in the slot area of <20 but the corrupted slots would always be higher numbers around the 80's.  

Share this post


Link to post
Share on other sites

You all are light years x2 ahead of me with this gear, but a rule I use for everything electronic device related is only do so many repetitive operations before you stop/save/reboot etc.  We get in the groove, and it is efficient, but historically I have found doing the same operation over and over (20+) on a device will often cause it to brain fart.

 

This comes from experience with software on PCs but more so from programming a Yamaha RX-7 for 30 years.

 

 

 

Share this post


Link to post
Share on other sites
6 hours ago, Lone_Poor_Boy said:

You all are light years x2 ahead of me with this gear, but a rule I use for everything electronic device related is only do so many repetitive operations before you stop/save/reboot etc.  We get in the groove, and it is efficient, but historically I have found doing the same operation over and over (20+) on a device will often cause it to brain fart.

 

This comes from experience with software on PCs but more so from programming a Yamaha RX-7 for 30 years.

 

 

 

I agree, but I have had it happen relatively quickly into a tweaking/jam session.  Even when I'm not even making tweaks to presets other than to realign songs within a setlist.  

Share this post


Link to post
Share on other sites
10 hours ago, themetallikid said:

when I had my issues with corrupted slots, it was around the 82 mark as well.  Sometimes I'd be rearranging a setlist for an updated setlist for my band, and I'd be working up in the slot area of <20 but the corrupted slots would always be higher numbers around the 80's.  

 

yeah every time the problem arises around 80-90, that seems to confirm the idea of some kind of buffer issue...

 

...could it also be that using 000-127 numbering instead of 01A-32D contributes to the problem?

I just wrote this idea to line 6 as a note to my ticket

Share this post


Link to post
Share on other sites

interesting concept.....I know nothing about programming or coding.....but I couldn't see how the display names would creep into buffer/memory issues.   But for the record I keep my preset displays on the 000-127 naming rather than the number/letter designations. 

Share this post


Link to post
Share on other sites

I havent tried yet. I'd prefer to 'not try', lol....but i'm sure with the new IR's that I purchased, I'll be resaving and moving some things around.  so we'll see.  lol

Share this post


Link to post
Share on other sites

Since 2.91 no issues so far .... let's hope it stays like that. I found that restarting the unit immediately after copying or moving a preset is helpful. Only after that I start tweaking it further. The "funny" thing is that sometimes presets will be "rebuilt" even though the copied/ moved preset was created in 2.91 and was put in an empty position. 

 

Anyway, so far so good, but I'm still very careful

Share this post


Link to post
Share on other sites

Corrupt presets are back with 2.91, at least for me. Everything worked fine and dandy until yesterday evening. Been playing with a pretty simple preset, just path 1 into path 2, no fancy stuff happening, bunch of drives, amp and IR, gate, volume pedal, delay, reverb, looper - and that was about it. Some pedals assigned to switches, 4 snapshots assigned. Not using any of the new pedals or Command Center options. Switched the Helix back on this morning and it just hung. Had to boot in preset restore mode (FS 10+11) which was then deleting the very preset that was loaded. I have an almost identical copy of that preset (just using a different IR) which is still working fine.

As this has happened before in pretty much exactly the same way, to me it looks as if the currently loaded preset is an easier victim of preset corruption. Maybe I should try to always load an empty patch before shutting down. Will be tough to remember as my entire home recording setup is sitting on one central power strip switch.

Share this post


Link to post
Share on other sites

hi guys

just to keep you all entertained, here is episode 4 of my bug quest ;)

 

this is the procedure I followed to have some material before upgrading to 2.91 and try to reproduce the error

as before I attached this text and screenshots to my support ticket

I have the impression that they will not look into it untill I upgrade to 2.91...

 

here it is:

 

 

- after some days of inactivity I just switched everything on

lauched hx edit and it gave me this error -8207 (see 200427a)

then I closed and reopended hx edit and it seemed ok

 

- then I renamed an empty user setlist

and imported with the white import button nine presets

and hx edit crashed see log "200427b hx edit crash log.rtf"

 

- my helix floor has always been connected to a rear USB2 port on my mac pro and it never ever gave me problems before 2.82

but I decided to try to connect it to a USB3 port on a PCIe card (sonnet allegro) of the same computer

 

then I rebooted helix and mac pro

the helix emitted a sequence of "train of impulses" like sounds for a couple of seconds then returned quiet

 

I lauched hx edit

and imported with the white import button the same nine presets (which are totally ok and worked in any firmware but I attach them anyway in the "200427e imported presets" folder)

 

then I reordered the nine presets inside the setlist by dragging & dropping them...

 

then I exported the setlist => multiple error -4 (see 200427c)

and presets from 96 to 101 now look corrupted (see 200427d)

 

 

- I repeat: my presets were only nine, I never touched the 96-101 presets of that empty setlist from my last full factory reset and backup restore

and it was a different setlist slot from the one that gave me the previous problems

 

 

 

- then:

helix factory reset (9+10 FS pressed on boot),

 

then I decided to NOT restore to my last full backup

and leave everything at factory default

expecially I left the default 01A-32D preset numbering and didn't change to 000-127, because other users on the forum that have had my same problems confirmed that they, like me, were using 000-127 numbering

 

I imported just eight of the nine presets,

I decided to exclude the one named "-- CORE barit --.hlx" just because it has "-" at the beginning of the name (it is a "placeholder": an empty preset renamed as a "title" of a group of presets)

 

see? I'm treating the helix like a dumb old fartass

 

then I reordered the nine presets inside the setlist by dragging & dropping them...

 

then I exported the setlist: it worked

 

- then I imported (always with the white button) the "-- CORE barit --.hlx" placeholder

and reordered again the presets

 

then I exported again the setlist: it worked again

 

- at this moment my presets are incomplete because I have not yet imported any IR

[I have saved my best original wav IR files in a folder: they are renamed to be readable in helix and with the helix IR slot number as a prefix so it's easy to import them]

so I imported 22 IRs using the import white button

 

then I exported again the setlist: it worked again

 

 

- then I changed from the defaults only one global setting: "Up/Down Switches" set to "Presets"

 

---

 

- I came back to the old USB port

- I worked for hours:

created new presets, copied them inside the setlist and modified them, exported sigle presets, exported the full setlist

all of this avoiding drag & drop for any operation

...not a single problem

 

 

- after weeks of not playing I just switched everything on, lauched hx edit and after a little time, it lost the connection with the helix floor so I connected it back back to the USB3 port on a PCIe card

and the connection was restored

 

then I worked for 2/3 hours without problems:

I modified presets in a setlist

exported presets and setlist (no drag & drop) without problems

then I imported another setlist on another setlist slot

I renamed it

and into that setlist I imported some presets and moved others (there is no way to re-organize presets in a setlist without drag & drop so I used it for a couple of files)

I exported the modified setlist and got some -4 errors (see "200513a.png")

and the last 12 presets of the setlist got the "strange names" corruption (see "200513b.png" and the corrupted setlist "oHne-M.hls")

those 12 presets were "New Presets" and were never touched by me

 

then I tried to overwrite the last 12 presets with non corrupted ones and got a -4 error ("200513c.png")

 

so I:

disconnected the USB cable

did a factory reset (9+10 FS pressed on boot)

leaved everything default

reconnected the USB cable and launched HX Edit

imported the IR's with the white IR import button

imported 2 user setlists (with the yellow setlist import button)

imported ONE user preset on a slot (with the white preset import button) and got a -8207 error ("200515a.png")

 

I pressed "ok" and then "reconnect" with no luck

 

so I restarted hx floor (it did a rebuild of presets)

and then launched hx edit

I noticed that after importing the second setlist I tried to import the single preset while the active loaded preset was still on another setlist

so I recalled a preset in the second setlist and imported the same preset as before on the same slot

and this time it worked

so it seems that importing (or pasting or dragging for what I know) a preset on a asetlist while the active loaded preset is in another setlist is a problem)

I finished importing some other presets

then I renamed and exported the modified setlist as a backup

no problems and no corrupted presets

 

I went on playing and modifying and exporting presets (with the white preset export button)

then I exported again the modified setlist (with the yellow setlist export button)

 

then I changed setlist and loaded a preset from it

then imported a couple of single presets (always with the white preset export button)

then I exported this other modified setlist (with the yellow setlist export button)

no problems and no corrupted presets

 

 

 

then just for testing:

I changed setlist without recalling a preset from it

imported a bunch of presets with drag & drop

modified some and reorganized them with drag & drop

exported them with drag & drop

renamed the setlist

exported it

no problems

 

then I rebuilt all presets (hold FS 10+11 on boot)

 

exported presets and setlists

no problems

 

then again just for testing:

copied presets from a setlist to another

exported presets with drag & drop

imported presets with drag & drop

copied presets inside a setlist with drag & drop

doing so I arrived to overwrite even the last presets of the setlist

then I exported the setlist

...I was not able to reproduce the problems...

 

then I changed global settings to 000-127 numbering

 

I imported a setlist with drag & drop

then another one

copied presets inside the setlist with drag & drop

reorganized them with drag & drop

again covering all the length of the setlist

 

and when I exported the setlist I finally got the -4 errors! (200515b.png)

then I exported all the presets in the setlist with drag & drop

(they gave no error messages)

then I reimported all of them with drag & drop

and exported again the setlist without errors

 

the folders "200515b test 1 & 2" are the result of the tests which gave no errors

 

the folder "200515b test 3" contains "_test 3.hls" which gave the -4 errors

and contains all the setlist's presets

 

200515c test 4.hls is the las setlist exported without problems

copied presets inside the setlist with drag & drop

reorganized them with drag & drop

 

 

 

next day I connected to a rear USB2 port on my mac pro and switched everithing on

(I was still on 000-127 numbering

imported 117 presets with drag & drop

reorganized presets with drag & drop

copied presets inside the setlist with drag & drop

covering all the length of the setlist

exported setlist

no problem (200516a test 5.hls)

imported a setlist with drag & drop

exported it

no problem (200516a USER 2.hls)

imported another setlist with drag & drop

copied presets inside the setlist with drag & drop

reorganized them with drag & drop

again covering all the length of the setlist

exported it

copied presets from another setlist

reorganized them with drag & drop

exported again the setlist (200516a test 6.hls)

no problem

 

then I repeated the steps that originally gave me the problem:

I imported 54 presets by fremen and 32 by mbritt (created and purchased before the 2.82 upgrade and used without problems before the upgrades, I think in 2.54 or 2.60)

I imported the original purchased versions (before rebuilding them with 2.82)

 

when I tried to copy some of them over others with drag & drop I got the original error:

3 or four subsequent -8207 error windows like the one in the screenshot "200516a"

and helix floor was freezed on a black screen

 

quitted hx edit

switched helix off & on: that automatically rebuilded a part of the presets

 

then 10 of the presets had strange names, see attachment "200516c"

also I noticed that not all the 32 presets were imported

the errors are around 90-99 slots

 

 

then:

1- I imported an empty setlist

2- I imported 50+ presets by fremen

3- reorganized them a bit

4- and then imported 30+ presets by mbritt

 

this time I got many many many many subsequent -8207 error windows like the one in the previous screenshot "200516a"

before theese windows there was another window for a moment but I couldn't read it

and helix floor was freezed on a black screen

when rebooted hardware and hx edit there were no "strange name" presets

 

 

 

 

then I changed port to a USB3 one on a PCIe card

and repeated exactly the 4 steps above and got exactly the same errors

 

 

 

 

then I changed the global preference to 01A-32D

and repeated exactly the 4 steps above and got exactly the same errors

 

this time I made a video to catch the whole "hidden" window

i'm attaching the video (200516d.mp4) and the frame of the "hidden" window (200516e.jpg)

there are a -8200 and a -8604 errors

by the way the -8207 error windows are 32, one for each of the presets

 

 

 

 

 

if you want, I can send you the fremen and mbritt presets, they are commercial presets so you need to use them only for testing purposes

 

please, remember that similar problems occurred with different kind of presets, rebuilt and not rebuilt by the v.2.82 firmware

I'm focusing on this error because it was the "worst" one and I was able to reproduce it

 

 

 

 

ok, now that I have reproduced the error and totally excluded a usb port problem

or the numbering option

I can update to 2.91 and repeat the steps to see if perhaps the bugs are gone

 

I'll try to find the time to do that in the next days

 

thanks
see you soon!

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...