Jump to content
Phazedwtfux

UX2 making loud noise

Recommended Posts

So sometimes my UX2 just makes a really loud ping/static/weird sound thats very loud, even if i unplug my microphone it still produces this sound but none of the levels are shown to be going up even on podfarm or my actual interface. i recently just upgraded to windows 10 and have had weird issues like my mic just gets super deep and bassy

Share this post


Link to post
Share on other sites

I have this problem too. Just noticed it. Scared the PEEP out of my. I was jamming to a tune and ZWAAANNNGGGGGG, I thought my ears were gonna bleed. My output levels on the UX2 flicked up with it. And it happened jiust a minute ago while  I was sitting at my desk. headset off and PC idol, I dunno...Sucks

Share this post


Link to post
Share on other sites

Mine does play up occasionally. Restarting the pc usually solves it, still on windows 7 and haven't updated since installation(that i know of). The drivers have been hit and miss on windows 10. Maybe try manually installing a few different drivers. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...