Jump to content
Halloumikev

Weird midi glitch. I want to understand!

Recommended Posts

Hey,

Came across a weird midi snag which has only occurred on one preset (so far). I've got around it but I would love to know what was causing it if anyone can help.

 

I've set up automation from Ableton using CC69 to change snapshots and PC messages select presets. It's fantastic. Just one of my presets did not want to behave. The PC message selected the preset but... at the beginning of the song, with the CC69 demanding snapshot 1; the light on the helix was indicating snapshot 2 with the actual sound being kind of snapshot 1 but with some differences. As the song progressed and other snapshots were demanded, the sound changed but the indication remained on snapshot 2.

 

My fault diagnosis:

I've tried a different midi track which works perfectly on another preset and got the same results.

I saved a different preset into the offending preset's slot and it works perfectly.

I saved a backup copy of the offending preset into the slot and it misbehaves.

 

Therefore, there is something wrong with this preset and I can't even begin to imagine what could be wrong with a preset to make it not like midi. 

 

I've got around the issue by just creating a new preset, I just want to understand. Any ideas?

 

To reiterate... there is nothing wrong with the midi implementation, I've proved this by substituting other presets. It is the preset at fault... somehow. Oh, and I'm on latest firmware etc.

PSA the offending preset if anyone wants to take a look.

 

Thanks

Shut up & dance.hlx

Share this post


Link to post
Share on other sites

Don't know why this preset should behave differently than any other, maybe some sort of corruption. I never use MIDI from Ableton like that, I set up my Snapshots to send the proper MIDI using ICs on each Snapshot, then record the MIDI from the Helix. Tell the truth, I'm not even sure how to do that (automation from Ableton), since I use Reaper for recording. I only ever use Ableton to play back loops into Reaper.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...