Jump to content
dawes1986

Glitch looper: unwanted lag via MIDI control, is this adjustable?

Recommended Posts

Hi gang,

 

It seems the Helix Rack's looper can't stop playback and start a new recording whilst in playback mode unless it receives a stop-playback MIDI CC message first. It also seems the stop-playback message needs to be received 20-21ms before the start-recording message, otherwise the latter is sometimes/often not acknowledged.

 

Is there any way to have the start-recording function override and force playback to stop?

Or alternatively is there an adjustable setting that'll make the Helix process the pair of stop/start of messages quicker?

 

I'm looking for immediacy with this so I can emulate glitching effects. Sending the two messages within 15-20ms is useable yet unreliable, and anything under 15ms registers only the stop-playback message, leaving the start-recording message overlooked. Anything above 21ms is consistently reliable, but the latency is off-putting.

 

What are my options?

 

Cheers!

Dawes

Share this post


Link to post
Share on other sites

If you're playing back a loop and want to start a NEW loop, you first have to erase the old loop. To do that you have to stop playback, then send RECORD again.

No way around it. I tried with my FCB1010 which can send two successive CCs, didn't work. You appear to be right about there needing to be a pause between messages.

There are ways to do it - BOME MIDI Translator, BOME BOX or MIDI Solutions Event Processor for use without a computer attached - , but no way I can see to do it without add-ons.

What are you using now to send the MIDI?

Share this post


Link to post
Share on other sites

Thanks, man.
 

Currently using Max/MSP to send the timed MIDI CC's from my laptop via USB. I have a Morningstar MC6 which can make use of an optional delay between it's CC messages but unfortunately it can't select a time between 0 and 100, so the 20-21ms pause–not ideal to begin with–is made way worse there.

 

The BOME and MIDI Solutions look cool, and thank you for suggesting them, but I'm disinclined as I usually run an AxeFx anyway, upon which the glitch effect has so far worked perfectly.

 

Nice to know I'm not the only one who's tried it with the Helix. What a shame to know there's no way to change it!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...